MSFS2020 error on launch [FIXED!]

I am getting this error when launching MSFS2020. same error from the MSStore and local from my PC.
Windows up to date
no new updates shown in the MS store
MSFS completely removed and re-installed - same error.

Do not know what is wrong …/ need help

msfs launch error

I seem to have repaired the problem:
1 Rolled back recent Win10 updates
2. Uninstalled the MS Store - Reinstalled
3. Uninstalled MSFS - Reinstalled
4. Cussed a bit
5. Swore a lot

Now the flightsim seems to be working. Thanks to all that replied

Which of the 5 items fixed the program? I likely will never know for sure

Try starting MSFS as an administrator.

If that doesn’t help, this is a link to the article in the sim “Support” section, found at the top of each page of the forum.

I do run the msfs as admin. I have set the properties of flightsimulator.exe to run as administrator.

1 Like

Have you updated Windows very recently, past 3-4 days? This may be a result of that in which it’s being looked into. I would check to see if you can roll back if in fact you did update.

I try to keep windows updated always as instructed by posted procedures for running this simulator. I have not rolled back windows update but will have a look at that possibility. I guess I just dont get how an installation and maintenence of any software can be so complicated and subject to failing so badly.

1 Like

I guess it depends on everyone’s system architecture. Personally, I’ve had in total since launch maybe 4-5 CTD’s and no issue actually running the sim. Though, there are others who have several issues and CTD’s frequently. Windows updates are a known culprit in terms of ability to break any game, which is why I suggested that. It’s a double edged sword.

Try this- look on the drive where your microsoft store installs apps to- you should see a folder called Wpsystem- Back it up and rermove it.

Hi there, How do you run it in administrator?

” then select Run as admin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.