MSFS2020 & IVAO's Altitude 1.10.4b

Hello, I am coming to post here as a last resort because I need your and I have not found it elsewhere.
I have posted several times in the dedicated support section for Altitude on the IVAO forum for various issues but I am royally ignored by the staff who have left my requests “Pending Approval” for days and therefore no one can’t see my posts and help me (yet view count increases so moderators read my posts).

In short, I present my problem to you:
I have MSFS up to date and I installed the Altitude 1.10.4b client (no other versions can be downloaded) and when I try to login to the client I get the message “invalid client software signature”.
I tried to install it (UI) on another computer and have it connect to the simulator pc (with the core) (disabling firewalls on both side of course), same problem.

I tried to run the client (Core + UI) in admin, before or after launching MSFS. Nothing changes.

I performed the installation following the dedicated manual, I also disabled my antivirus and firewall during installation as well as during use. The problem remains the same.

If you have an idea, I’m interested.
Thank you.

Screenshot of the error

A fix that can solve your problem.


Thanks for your reply but as indicated i’m on the version 1.10.4b but the hotfix you give me is for the version 1.10.3b.

This is the error message i’ve receive when launching Altitude : Altitude 1.10.4b with Hotfix 1.10.3b - Album on Imgur

starnge things happening on altitude, probably i am missing old versions