My 2070 SUPER VR settings and suggestion (Reverb G2 - WMR)

Interesting. I’ll experiment with increasing OXR to 75 - maybe it will improve the juddering (is that the term for what I’m describing?) because there’s less overhead. I tried OXR80/TAA100 but there’s a lot of stutter. My 3080/5900X can’t keep up, that’s too high load.

I resisted using MR for the longest time because it felt too fake and I couldnt get past the warping. Newer OXR as well as prop transparency mods have made MR way better and I have switched over to full time MR.

I say that because in all my previous (non MR) testing, I would always get slightly higher FPS with hyperthreading enabled in my BIOS even though the prevailing wisdom is to turn it off. Well, once I really started dialing in my settings with MR enabled, I was experiencing similar “micro-occurrences of differing frame rate”. Thats the best description I could give it.

Anyway, after adjusting every setting I could think of, I finally went in and disable hyperthreading and sure enough, those micro-whatevers seemed to vanish.

I’m running a 10850K with a 3090.

You may already have HT disabled… but food for thought…

1 Like

I can run the FBW320 at TAA70+OXR100+Clouds HIGH/MED (depending) in the air, TAA65+OXR100+Clouds MED on the ground, on the 9700K+2070S.

Otherwise with 1.19.9 I get much more reliable motion smoothing with TAA85+OXR80 (and better looking EFIS than with TAA70).

Eventually 75/75 is not too bad for motion smoothing but you loose a little on the outside details and not gain much in the inside details, but motion smoothing never fails nearly.

These are just a few TAA/OXR test points you might want to experiment with, but this really depends on the type of flying/aircraft, considering the higher OXR, the more outside details but the higher resources for motion smoothing, the higher TAA, the better the EFIS (ideally TAA100 for these). Finding the balance between the two when the hardware can’t sustain 100/100 is an art sometimes!

I want clear outside so much, that I think I’m willing to sacrifice a bit of EFIS clarity. So for the outside, should I lessen TAA and set more OXR? For now I fly mostly GA. Eventually I will fly more airliners. I like 737 the most, but so far no good one in MSFS. And the scenery is so great to enjoy with GA.

Interesting if it could also help my regular judder every 1s. Unfortunately AMD equivalent of hyperthreading disables sleep mode completely in Windows. Supposedly by design, so it’s not a bug. Weird design decision. So I turned it back on, after not seeing any noticeable performance difference. But I will try it off again, see if it helps my problem…

Thanks for that, I’m pretty sure it’s disabled but I’ll check anyway, maybe enabling it will help me.

I tried a feww things today, simultaneously with calibating and tuning my DIY motion platform (oh, what a joy!). Tested in Bonanza G35 with G1000 NXi in Graz / Klagenfurt area - Alps mountains and photogrammetry are in Graz.

  • Disabled SMT (AMD hyperthreading, disabling it also disables sleep mode). No noticeable effect on those 1s hiccups.

  • Moved rolling cache to Ram Drive (16Gb out of 64Gb 3800Mhz RAM). Didn’t vure the hiccups completely, but it’s possible that it has improved it a little bet, difficult to tell, may be placebo or other factors involved.

  • Tried OXR100/TAA70 - reverse of my usual OXR70/TAA100. Much sharper both EFIS and outside but performance went down the drain, unplayable, low FPS, MR fails all the time. Lowered TAA in flight down to 60, then 50 - not impressed.

  • Tried OXR85/TAA85 - that looks surprisingly sharp. Seems like both outside and EFIS are sharper than my former OXR70/TAA100! I really like this, I think I’m going to stick with this ot OXR80/TAA85 like you recommended. 85/85 felt a bit borderline. Hiccups are still present, but after enabling RamDrive they seem to be a bit less prominent.

So, next I’m going to try setting OXR80/TAA85, and also limit FPS for MSFS in NVIDIA CP to something like 24, so it never goes up enough to trigger next MR mode. Maybe that will help with hiccups?

1 Like

This is an interesting comment!

I’ve always stuck rigidly to WMR native on my G2 for performance reasons, even though the functionality in SteamVR is much greater, e.g. the number of tools/overlays available in SteamVR.

If this is true, then I will surely flip over to SteamVR…!


I’m actually saying it used to, but it isn’t anymore!

Oh yeah! I read that comment wrong. D’uh. That’s a shame!

I thought native WMR OXR has always been better than SteamVR for WMR on WMR headsets? I didn’t realise there was a time when SteamVR was better than WMR OXR? Oh well, thanks anyway…

1 Like

For me native WMR OXR was always better. Maybe because I need MR, I’m sensitive to low FPS and can’t stand 60Hz too. It’s just unbearable to me. So never tested without MR. With MR SteamVR OXR with G2 always was plainly unusable for me. Jerky and it also twitches back to where my head was a couple of seconds ago. It’s like it does a few frames then pulls a frame out if it’s ■■■ where if was for the last 2 seconds, then goes back to present, and it’s constant. Feels like broken tracking or broken MR. But in native WMR OXR tracking is almost perfect, I have no problems with tracking whatsoever. Only with stutter in the sim, or rather what I call “hiccups” every second or 2 seconds. Otherwise it’s butter in the air and almost butter on the ground.


I experimented some more.

  • Capping the FPS at 23 or 24 or 30 doesn’t make any difference but instead makes things worse.
  • Changing to any OXR/TAA combination makes overall clarity and smoothness better or worse, but the 1s hiccups are still there. Overall I thinkg OXR80/TAA85 gives me the best compromise between smoothness and clarity.
  • This doesn’t seem to be connected to MR jumping above 22.5FPS to 30FPS mode. Limiting FPS or changing OXR/TAA would have solved it but it doesn’t.
  • On some settings, when everything is really smooth, it seems that those hiccups can become the “rubberband” issue when scenery slows down then speeds up. I think those issues are one and the same. Just on less FPS scenery jump, but with more FPS it “rubberbands” back to speed.
  • Moving rolling cache to 16Gb RAMDrive does’t seem to help a lot. A very minimal difference if any
  • Preloading Med to Ultra doesn’t seem to affect the hiccups.
  • Disabling SMT (SMD hyperthreading) doesn’t help, it only disables sleep mode in Windows.

I don’t know what else to do, I expected more out of 3080/5900X/64Gb RAM PC with this sim. Well, let’s hope they optimize things for VR more. It’s still enjoyable, it’s just annoying to get those fluctuations in movement so often and regularly, while between them it’s so smooth I want to cry. If that smoothness was constant, I’d be a very happy man. Now, with virtually completed motion platform rig with transducers, encoder box, and VR it’s already the best sim experience I ever had. I wonder what could be causing those hiccups.

1 Like

I have a 5950x and a 3090 with a g2 and I get around 30-35 fps with 100oxr 100taa and most things on ultra. The thing that really kills my rps is the real life ultra clouds (a must for me), and I don’t mean looking at then or the nice fluffy one’s that make great screenshots. I mean travelling through either the misty high level ones or ones with rain, it drops my fps down to around 22 and very jerky, so much so those black sides appear if I move my head quickly. I keep trying MR with every oxr or driver update in the hope it improves but for me it’s a no go.

I’ve tried steamvr a few times and I’ve come to the conclusion I must be doing something wrong. Ive read posts saying it’s either better or as good as oxr but I just can’t get it like that at all. If I have MR off it is incredibly jerky and if it is on the view bounces about all over the place. I have the same in game settings as mentioned above and 100% steamvr. It does look super clear, but reducing either steamvr or taa to an acceptable frame rate reduces the clarity below that of 100oxr 100taa.

So strange you are getting a regular fluctuations. I have a similar rig to you and although I fly mostly gliders atm, without MR I get a very smooth experience, except of course for rapid head or airframe movements, which settle down very quickly, so I hardly notice. I’m running a set 30fps in Radeon software, with clouds at ultra and in-game RS at 100 and OXR at 90 (I can use 100, but it’s right on the edge of acceptable). I run a mix of high and ultra settings with some shadow stuff off or low. I value sharpness and resolution very much and right now the sim looks great. My cockpit is pin sharp with the G2 now, as are the wing and fuselage edges and the scenery.

Maybe you have something that’s eating resources at a regular rate interval, like anti virus or something?

Ryzen 5600X
Radeon 6800XT
32 GB 3200 RAM
Rolling cache off.

Hmm… this got me thinking… I wonder if there is a way to monitor the usage of every process running in a graphical way that may point to some regular spike by some process that could be causing the hiccups.

A little google-fu lead me to This Post, so I decided to try it myself (even though I am not experiencing any stuttering) and wouldn’t you know, I have this “lighting service” process that is eating a bunch of CPU time… turns out its related to the Aura Sync software that controls RGB… so I’ll be investigating that (and deleting the app if necessary).

Might be worth a shot to set this up and see if you can find any patterns that correlate to your hiccuping…

1 Like

My problem may be related to MR. Unfortunately I can’t stand low framerates. I guess different people perceive motion different way, may can enjoy a flight without MR at 30fps - I simply can’t stand it.

I use a dual-boot config with clean Windows install just for MSFS, with all antivirus etc. disabled.

It’s actually a great idea. Although I knew that those processes can eat CPU so MSFS windows install in a dual boot has all of that lighting thing not installed. And generally it’s as slim as possible. But who knows. I am running MobiFlight for my VR encoder/button box, FSUIPC, SimShaker + SoundModule for transducers, and FlyPTMover for motion rig. One of them could cause a problem, or something else can. I will check.

CptLucky, that is an interesting find. I played around with the value a bit, and it controls a kind of “predictive motion smoothing” that was introduced into WMR recently, and which has been driving me nuts ever since it appeared, haha. When it first appeared I thought something was wrong with my headset. You can really notice it in the WMR home. Whenever you turn your head side to side you can see that the vertical walls have some motion blur both ahead of and behind the direction of motion. If you set that reg key to 0 it disables the effect, which is lovely. Not sure what the other two keys you noted do, but just thought I’d mention that one.

Cheers, and thank you!

1 Like


If you use Aurasync. Det it to display a fixad colour. Then it won’t use any CPU. If you have it on cycling colour schemes like rainbow etc. it uses some CPU. In my case it used up ti like 12%…which is insane :grinning: to run RGB lightning.

First I run everything at stock clocks (CPU/RAM/GPU) and oserved no improvement on microstuttering.
I then looked at my running processes. No lighting because I didn’t install it. The ones that were most noticable, other than system-related, were:

  • FlyPT Mover (controls my DIY Motion Platform rig). Closing it down didn’t make any difference in microstuttering.
  • VoiceAttack (I use it to interact with MSFS) - no change if closed
  • Precision X1 (EVGA 3080 control panel - overclocking, cooling etc.) - I closed it and saw a massive improvement on microstuttering! Not that I didn’t see a stutter here and there, but they were rare, and were far between. There was no 1 to 1.5 second microstuttering that was driving me nuts! It’s not perfect but it’s much closer to a constantly smooth experience. I tested a few times - as soon as I enable Precision X1 - I get more frequent microstuttering, even when it’s set on stock clocks. As soon as I close it - situation significantly improves.

Now I wonder if the modest overclock settings I can load with it stick after I close it? I’d like to use all the power I can get, and I have OC BIOS that allows me to raise power and temperature max, and dial a bit of stable overclock (+200 memory, +110 Core - it’s really not much but FTW3 is a high-clocked 3080 from the factory, so this is the most I can push while remaining 100% stable). I wish I can load it and close the software… Not sure if I lose the OC when I close X1…

I also tested with MR disabled - nope, still can’t stand it. If there’s any clarity improvement it dies as soon as I move my head even a little.

It also seems that performance is a bit better when I uncheck “use custom resolution” in OpenXR. I know it automatically sets the resolution based on VRAM size. But it seems to look as good as OXR80 and I run it with TAA100 and I think it’s smoother than OXR85/TAA85. But that can be placebo effect.


I seem to be getting inconstant performance from one day to the next, which I think may be network related. MSFS is highly reliant on efficient data streaming and possibly also my local internet congestion.

Just something else to muddy the waters.

However, I have noticed that I can now use Motion Reprovomit with my rather high settings, using a heavily overclocked Radeon 6800XT, for things like reliving my flight training at a regional airport in Oz on a C152, and it’s not totally terrible.

I just wish someone would model the Piper Traumahawk, so I could once again see the world whiz around in a death defying spin, with my instructor pinned to the side of the cockpit screaming her head off, lol.

Edit: Text may be exaggerated for comic effect. But the Piper Tomahawk really did spin like a female dog.