My CTD issue might be fixed!

No CTD in a week of flying!

It was CTD HELL two weeks ago.
I did these things by experimentation. I am NOT saying any of it will fix you.
First, I shut down overclocking.
Second, went to my monitor manufacturer and downloaded/installed their specific driver for my monitor. Not looking to let W10 choose.
Third, after noting MSFS settings showed a resolution that did not match the native res for my monitor, reset Full Screen Resolution. Also, Render Scaling slider set to 100 matching Rendering Resolution to Full screen number. V-Sync to off.
Fourth, starting Global Rendering Quality at Low End moved up a step at a time. Flying the same short flight at each step. After reaching high end setting I setting I changed individual settings to what looked best to me.
NO CTDs in 7 days of intense flying using lots of Community folder stuff and nearly every default and every payware/freeware aircraft I have.
It was 2 days of testing.
I am amazed at how beautifully MSFS is working for me now.
Best wishes to you all. Jim

5 Likes

Its a mixed basket for all of us. I had massive CTDs prior to su5. After su5, no more CTDs. Only change ive done is updated to latest nvidia driver. No reinstall msfs, nothing.

Seems to be no rhyme or reason for CTDs

Certainly if your Overclock was only marginally stable certain workloads might expose it’s weaknesses and CTD’s might then occur.
MSFS2020 does push hardware quite a lot.

2 Likes

I’d say most of my early CTDs were caused by the FBW A320. When it was removed everything was fine.

All of my issues were either caused by addons or forgetting to return my cryptomining settings to normal before running msfs. No CTDs at all other than these.

Removing any overclocking is clearly the first course of action anyone should consider along with keeping an eye on CPU and GPU temperatures. Making sure all drivers are up to date goes without saying.

The screen resolution one was an interesting one. Not sure what to think about that though it stands to reason that you should be running at your monitors native settings.

Finally, some users might just be trying to run msfs at settings too high for their machines. Going from ultra to high or from high to medium might be all you need.

I got CTD hell with the update. I submitted event logs and videos of the events. Their response was to reset the sim graphics: set them to low, save, then reset them to high or ultra. That fixed it for me. I still got one or two CTDs since, but it was not every flight.

That is what you did, starting at low then working your way back up.

The other things are good measure, but not the real solution to the problem. The sim shouldn’t CTD one year after release. Plane and simple. Pun on the plane-plain. Haha.

1 Like

End of thread :slight_smile:

1 Like

GPU overclocking causes 99.9% of CTDs

That’s a bold statement, and I find myself proud to be part of the 0.1%.

I haven’t had a crash in a while now, for two possible reasons.

  1. I stopped using cached scenery.
  2. I use ATC with Azure TTS very sparingly.

The downside to 2 is that some of my take-offs, and landings are not logged correctly

I stopped my CTDs entirely by moving my install off an SSD and back on to a HDD. Had tried literally everything else over the previous 6 months.

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000000adfac6
Faulting process id: 0x4118
Faulting application start time: 0x01d7b25da406bfe2
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.19.9.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.19.9.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: f87283fe-6c25-42eb-b7bf-c7f9ee544ef3
Faulting package full name: Microsoft.FlightSimulator_1.19.9.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

The ■■■■ problem I have is that cannot find this path !
Can’t troubleshoot the stupid fault at all.
Come on P3D !!! I miss not CTD.

If you want to see \Program Files\WindowsApps click the View tab and check Hidden Files in Explorer,

… but there’s little chance you can “trouble shoot” anything there, alas

Yes, thank you dude !
I figure that one out recently.

You are right. won’t sort out much. Still waiting for a non CTD experience in FS2020 !