My joystick works and it says It does in the menu, but when I fly it does nothing

This is not a problem with addons as yesterday after the update my Logitech Extreme 3D Pro worked fine, but now I loaded up the game to do some flying, and I moved my joystick around and it didn’t do anything (in game when I was flying) then I went do the menu to check if my joystick was plugged in, and it was I checked the imputs and It said it was working (the white line was moving just as it should be, so I thought it was fixed to I went and unpaused the game, nothing.

I have mods but it worked yesterday, there is no way it is mods.

Did you check your Options, Controls and your Joystick?

Is it there and is it programmed?

Make sure Control Aircraft in “AI Control” dropdown is not selected (easy mistake to make) and try again.

I have it off, and my joystick is configurated. I also see the joystick moving in game but not the throttle, my throttle did work until I quit the flight.

I figured out the problem with this, simcommect.cfg was in my documents folder and that was the problem I was having