My usual way of using ILS seems to have stopped working, help appreciated

Hi :slight_smile:

I sometimes use ILS to land my plane, usually the Cessna 172 G1000. Here is my routine to do this :

1-setup the flight in the world map to use ILS
2-in the cockpit, if it hasn’t been entered already, enter then NAV frequency
3-begin flight, once in the air press the AP button, then the NAV button

then enjoy a relaxing flight until near the destination where I press APR when lined up with the airport.

But pressing the NAV button in step 3 isn’t working the same way as usual. The plane does not follow the correct route. The G1000 only shows LOC1 and not GPS. I’ve noticed, and I suspect this might be related to the problem, that the pink line indicating the route on the right hand side G1000 map display is not displayed anymore.

I hope I’ve explained my issue well enough, I’m not very clued up on the correct terminology etc.


There is a Nav/GPS switch that must be on GPS if using the autopilot to follow a plan you entered in the World Map. Once you are lined up on approach and want to use the ILS, you have to switch back to Nav.

On glass panels (or the GTN750), you can use the CDI selector for Nav/GPS.

If you have been doing this already, let us know so we can look at other possible answers.

1 Like

Hmmm… maybe there is another clue here… " the pink line indicating the route on the right hand side G1000 map display is not displayed anymore."

I have loaded flights before where the plan set up in World Map isn’t transferred to the aircraft when loading the flight. Might be a WT update to mimic realism. I can’t be sure about that. But I have seen it many times and I’ve had to program the flight plan from the aircraft.

To check, bring up the flight plan on your Garmin. If it’s not displayed, that’s the issue. You will need to enter it manually.

1 Like

press the CDI button to change the nav source to GPS.

1 Like

thanks for the input so far.

i pressed the CDI button, it switched to GPS on the display, i turned AP on, pressed NAV, but no magenta route line appeared on the map and the autopilot didn’t fly towards the destination.

on the screenshot below, i think this shows the flight plan has transferred to the aircraft computer.

the magenta flight path line on the map is just not showing like it used to even though the flight plan has (i think) been transferred from the world map. i tried a vfr flight plan, the magenta line appears ok and the autopilot follows this flight plan. i tried updating to the G1000NXI but still the same. not sure what to do now. i’m not sure exactly how to program the G1000 manually so i’m going to watch a tutorial on it and try that.

in this pic, the departure airport (EGGP) is about 10 miles north of the destination airport (EGNR), note no magenta line on the map even though the flight plan appears in the garmin computer (FPL button).

See if this helps. Using the heading button get the plane close to the desired route. Once the plane gets clost to intercepting the course line activate the NAV button and see if the plane will follow the course.

1 Like

It looks like you don’t have any active part of the route. Mangenta is only the current part of the route to the next waypoint. The other (next) steps are white.

After finishing my flight to San Juan i will try something.

Are you flying on Xbox or PC?

1 Like

i tried this but the AP didn’t follow the route. i then tried using the PROC button, then APPROACH from the subsequent menu, then ACTIVATE, then tried what you suggested and it worked (it intercepted the route, then pressing APR once the GS indicator was showing it landed the aircraft)! Pressing AP, then NAV it followed the route on the map (which had also turned from white to magenta). so it works ok now but it is definitely different to how it used to work. why it’s changed idk.

Thankyou. I think by using the PROC button etc as i’ve described just above, that the route became active (turned from white to magenta on the map). I’m on PC.

I believe that something is messed up in your G1000. In the G5000 in the C700 f.e. i see settings from the last flight. But i loaded a complete new flight

I agree. I don’t think there’s anyway to reset it other than a full re-install, so I’m considering doing that.

I tried the King Air with the G3000, exactly the same setup routine in the world map for using ILS, and the route was shown as expected like it had always done up until recently with the G1000, so i think i have some issue with the G1000. I’m re-installing the sim (sigh).

The problem is you’ve selected an approach with a vector to final, or “VTF.” This requires you to fly headings manually (at the behest of ATC) to get you aligned with the final approach course.

For a multitude of reasons, in the real world, we don’t select or file an approach in the flight plan. I think the sim is moving toward that in the background coding, but at this time it still allows the FPL generation using approaches in the world map. I’m not sure if or how they’re going to reconcile that.

1 Like

The problem is my usual method setting up an ILS flight in the world map, that i’ve done for over 2 years without fail, is not working anymore. re-installing the sim made no difference.

Reinstalling won’t help. In AAU1, they aligned the operation of the in-sim navigators (GNS530, etc) to act as they do in the real world. Under the previous guise, using the world map would inject fake user waypoints to smoothly connect the route (or arrival) to the approach, but that’s not really doing an ILS, because ILS (VOR, GPS, etc) approaches are all about the procedure - bypassing it becomes “ILS-ish.” At the same time, when doing it the “right” way, those fake waypoints caused very erratic behavior.

I’m not sure if they’re going to find a middle ground that works for people looking to have it behave correctly and those looking for a turn-key method, but I suspect that fixing the underlying issues with the nav data and the way the program uses them was the first step and there will be more to come.


ok thx for the explanation. bit disappointed they’ve removed a feature i often use. ok i can do it the proper way and i have learnt more about this over the last 24 hours. i’ve noticed i can still use my old method with G3000 equipped aircraft so there’s that, but i suppose that will be removed eventually.