Need Help regarding re install of sim on new drive

Hello, I recently got a new external drive and attempted to switch my sim over from my stock C drive to the new D drive. In this process, I tried doing the default “move app” in settings and there were multiple problems I faced.

Since then I have uninstalled MSFS completely and attempted to re-install it on my new drive. The problem I current face is my download gets stuck at “1/178 - Decompressing fs base cgl 0.1.75 fs package” I have tried twice now to completely uninstall and re-install and have been stuck here now.

Any help would be greatly appreciated so I can get back up into the beautiful skies of MSFS.


By external drive you mean a USB one? Did you format the new drive before using it?
Never happened to me but it does look like MSFS is unable to extract the files into the new drive… Share some more details if you can so we can try troubleshoot

Yes it is a usb drive. I created a folder in the drive for msfs.

In the Official One Store files on your PC, delete the fs base cgl folder and retry.
That often will fix the issue.

Will i need to download them back after the fact and if so how?

You just restart the sim, and it will re-download that folder.

Ok I will exit this and attempt to redownload after deleting them.

I did it by copying the folders Community and Official to the new drive. Then you have to tell MSFS were teese folders are.
C:\Users\your name\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

open UserCfg.opt with the editor
and change the last entry for example: InstalledPackagesPath “H:\Flusi 2020”

Was able to get in and get everything downloaded. However, when I load back into the sim now, it keeps taking me to the game service app page on microsoft store.

That’s ok, can you start the sim from there?

I’m currently having a similar issue, however I don’t have a fs-base-cgl folder, there are a lot of fs-base-cgl.PART files and one fa-base-cgl.RAR file, after deleting all of them I’m still asked to reinstall the entire update from the beginning. Any advice?

Im unable to start my sim now, as it goes to the game service page. It allowed me to start and even fly on the first load in, but subsequent ones it won’t.

It depends on where the install stops. That is the folder to repmove.

From the Window’s Apps and Features menu, have you tried resetting Gaming Services?

Yea, I have tried reset, repair, I have also tried to delete it and use Powershell to re install it. Not sure what the problem is.

1 Like