Need Serious Help With "Sensitivity"

I am having severe problems with the Sensitivity settings. My aircraft is reacting violently to rudder inputs. When I make a moderate turn, nothing happens until I have my yoke almost all the way over, and then it turns severely and it take complete reverse rudder to correct it, but then the turn is just as violent, and I end up completely out of control. Using a Honeycomb throttle and yoke. Can someone suggest how to adjust the sensitivity settings to prevent this? I have played with them, but I just seem to make it worse! Many thanks!

Sounds like you have an extreme amount of dead zone. Nothing happens and then when the controller cuts in, it’s too much. Check your controller sensitives and reset them to default and see what happens.

I’ve set rudder sensitivity to -70%! (in words: minus seventy percent!)

I have VKB rudder pedals that are also very sensitive. I have sensitivity set to 45, dead zone to 5 and reactivity at 90. Play around with the settings - there are also some good YouTube videos explaining what all the sensitivity settings do. Like this one:

Well, I might have the problem figured out, but I don’t know how to fix it! When watching the airplanes in the external view, it appears that with the slightest movement of my yoke, the rudder goes into the extreme left or right locked position and the plane literally sits in one place and goes around in a circle! I have returned the sensitivities to default with no result apparent. Any movement of my yoke, left or right, causes this problem. I do not have rudder pedals (yet) and the assistance setting is not set to auto rudder. I have never had this happen in MSFS before. Any suggestions would be most welcome! Thanks again!

You probably have the rudder axis or incremental commands bound to another controller axis or button. Check all the axes connected to the computer.

I completely deleted all profiles except Default. That solved the going around in circles business so there must have been some conflict or a bug somewhere. But now, I have almost no control on the ground. It seems like my rudder isn’t even there. I cannot turn off of a runway once I slow down. Ah, the joys of MSFS! All sensitivities are at default. As I mentioned, I have no rudder pedals yet, but I might just be heading over to a supplier to purchase a set in the next few days. (As soon as I convince my wife that rudder pedals are cheaper than a new pickup truck!) Thanks for your help!