Negative flaps on Flight Design CTSL increase drag, not reduce it

As per Flight Design CTSL - Cruise Flap Setting (-12) no change in drag / airspeed it used to be that the negative flaps on the Flight Design CTSL didn’t affect speed; the release notes indicate that they should now correctly decrease drag (thus increasing speed) however in my testing they are massively increasing drag, producing a major loss in airspeed.

Are you using Developer Mode or made changes in it?

yes and no, doesn’t affect outcome. no changes made.

Brief description of the issue:

As per Flight Design CTSL - Cruise Flap Setting (-12) no change in drag / airspeed it used to be that the negative flaps on the Flight Design CTSL didn’t affect speed; the release notes indicate that they should now correctly decrease drag (thus increasing speed) however in my testing they are massively increasing drag, producing a major loss in airspeed.

Provide Screenshot(s)/video(s) of the issue encountered:

before deploying negative flaps:


after deploying negative flaps and stabilizing level flight

Detailed steps to reproduce the issue encountered:

  1. Load a flight with the Flight Design CTSL
  2. Take off and reach some cruise altitude (I tried 4000 ft) and comfortable speed (say, at 4800 RPM you might get 190-200 km/h)
  3. Deploy -12 degree flaps and adjust trim to stabilize for level flight. You should get an increase in speed once leveled out; instead I see a massive loss in speed.

PC specs and/or peripheral set up if relevant:

n/a


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Testing on final SU10 release, on Xbox since I’m away from my PC this week:

Not fixed.

-12 degree flaps on the CTSL still slow the plane down quite a bit, not speed it up. This despite it being listed as fixed in the release notes:

1 Like

Moved to #bugs-and-issues:aircraft-systems.

1 Like