New Rig with RTX 3090 and Reverb G2 need settings advice

I’m currently flying VR MSFS 2020 with laptop with 32GB DDR/nvidia 2080 Super 8GB GPU/ i7-10875 at 5.0Ghz/Reverb G2. I have settings pretty well dialed in with Open XR rendering at 70 and MSFS at 70 rendering with settings pretty much all low which is providing a very smooth albeit a bit blurry experience. With an overcast, or highly populated area, the system CTDs after about 1 hr pretty consistently because of GPU limits. So, I purchased a desktop with an RTX 3090, i9-10900 at 5.3Ghz, 128GB dual channel HyperX DDR4 at 3200Mhz, and 2TB SSD with the hopes a) I can run VR at higher/clearer settings and b) avoid CTDs.

Can you provide me with the optimum VR settings for MSFS 2020 with the 3090 system to include optimum windows 10 settings, Nvidia control panel settings (and best driver–I read that 457.30 was the best for 3090 and MSFS), and VR settings in Open XR and MSFS 2020. I believe I saw a youtube with VR fltsim guy( he has a 3090) I think and he mentioned setting 70 in Open XR and 100 in MSFS 2020. Any other advice would be great.

Thanks in advance!

Congrats on your new rig! I have an RTX 3080 with an i7 10700K, and set rendering in MSFS to 80 and in OpenXR to 90, and I get a pretty smooth experience. However I find my CPU overheating, but that may be a localised build issue. I can’t test anything in VR right now as my G2 failed yesterday and they are replacing it.

In game graphics settings are based upon a thread by Cpt Lucky in these forums. His settings were based on a 2080 (I think) so I’ve managed to go a bit higher. Best is to experiment a bit until you hit the sweetspot for your system and your preferences. He also has recommendations for Nvidia control panel and various windows settings. (Sorry, I don’t currently have a link to that thread.)

With your specs you should be able to go pretty high. My game was very smooth on the whole, just got a bit juddery when landing and taxiing.

1 Like

Copy thanks! My question is the relationship between Open XR rendering and MSFS rendering. Will a lower setting in Open XR result in less clarity or do the MSFS rendering settings have a greater impact on clarity. I’ve seen vrflightsimguy with a 3090 use a lower setting in Open XR–70 I believe, but then cranks MSFS rendering to 100 and it is both clear and very smooth. With my 2080 and laptop temp limitations, I’m pretty happy with the VR visual experience, but hate the unexpected CTDs due to memory lims on the 2080. Dialing volumetric clouds down to low or flying with clear skies only sucks.

@KemoF15 I’ve spent the last few weeks agonizing over this configuration, and here are the settings that I’m liking right now (5950X/3090)

OpenXR render scale: 65%, Motion reprojection Auto (on)

Vertical sync: OFF

VR Flight Sim Guy uses TAA100 + SS70, and these settings are TAA100 + SS65.

Note that you’ll want the best CPU you can get. The sim will use all of it.

There aren’t really any perfect settings for any given hardware configuration. The best you can shoot for is “pretty good most of the time”. And as much as people hate to hear “it depends”, it really does depend on how you use the sim. FS2020 VR is so taxing on hardware that you have to pick your tradeoffs, even on the highest end hardware.


3090 + 8700k here. 50 in oxr + 100 TAA gives great frame rates with motion repro off. Most settings to ultra a part from ambient occlusion and contact shadows to low, and a couple of others to high. I get strange skips/stutters that are unrelated to frame rate with any configuration though - but that’s another story. Ah yes as mentioned cpu peaks at 100C

Yikes. No matter the load, your CPU should never hit 100c. You must have OC’ed? Or you have a hardware problem (wrong application of CPU thermal paste could be one)

Yes I know. Thermal paste probably. But to be fair I have never ever hit 100 before using msfs in vr. Maximum peaks at 85

1 Like

Where? Because unless you are OC’ed and running a Prime95 stress test, you’re still running hot.

You are going to burn out your chip if you don’t deal with that issue. Seems silly for the…what $6 for a tube of thermal paste?

Yep, I never really had an issue before playing MSFS in VR, so I think I am about to order some thermal paste and perhaps a new cooler too!

Leave openXR alone if you have a 3090. Trust me it’s not with fiddling with. Just set 100TAA in sim and enjoy it.

From my post in the other topic regarding this:-

Hi, So, render scale at 70% in MSFS after this recent update is horrendous. Blue outlines all over the place and flickering image. So, I tried 100% in sim and then 70% in OXR. This then reduced my sweet spot quite a lot, so I did not like that.

So, out of curiosity, I just left open XR at all defaults, and set the sim render scale at 100%.
I am running a 3090 . I thought it might have auto adjusted the resolution down ( I kept checking), but it didn’t. I added some clouds, night time etc… day time. Stress tested it.

Man, why was I messing all this time?! 100 render scale in openXR and in sim is so sharp! The sweetspot blends so much better! And the performance is WAY better than I expected it would be. Its actually really smooth too! I think I will just leave it like this now, its what the G2 was designed for!, and let them craic on with optimizing MSFS.

PS This is with an i9900KS at 5GHZ and also using high refresh rate in cockpit with the Beechcraft bonanza glass cockpit.

I have OPENXR with use latest preview unselected.
I have OPENXR with custom render scale unchecked.
I have OPENXR motion reprojection disabled.

In sim I have:-

Render Scaling = 100 TAA
Terrain Level Of detail = 100
terrain Vector data = Ultra
Buildings = High
Trees = High ( I also have an extended tree mod installed)
Grass and Bushes = Medium
Objects level of detail - 100
Volumetric Clouds = High
Texture resolution = Ultra
Anisotropic filtering = 16x
Texture supersampling = 6x6
texture Synthesis = Ultra
Water waves = High
Shadow maps = 1024
Terrain Shadows = 1024
Contact shadows = medium
Windshield effects = High
Ambient Occlusion = low
Reflections - medium
Light shafts = Medium
Bloom = On
Glass cockpit refresh rate = High

3152x3088 for both game and post. (checked with dev tool)


My new rig (6 weeks old) is an i9, 3080, 32gb, 1000 w ps, liquid cooled, HP G2 headset. I am running the nVidia driver is the 457.51.

My OpenXR settings are:

Latest Preview : Unselected
Custom Render Scale: Checked and set at 100
Motion Reprojection: Disabled

In the Sim on the VR panel:

Render Scaling = 100
Terrain Level of Detail = 200
Terrain Vector Data = Ultra
Buildings = Ultra
Trees = Ultra
Grass & Bushes = Ultra
Objects Level of Detail = 200
Volumetric Clouds = Ultra
Texture Resolution = Ultra
Anisotropic Filtering = 8x
Texture Supersampling = 2x2
Texture Synthesis = Ultra
Water Waves = High
Shadow Maps = 2048
Terrain Shadows = 2048
Contact Shadows = OFF
Windshield Effects = OFF
Ambient Occlusion = High
Reflections = OFF
Light Shafts = OFF
Bloom = OFF
Glass Cockpit Refresh Rate = High

I typically get around 35 fps. I don’t generally fly in places like New York but I did recently fly all over London with similar results (maybe 30 - 35 fps, if I remember correctly).

My search for settings is all about clarity / sharpness. It is the reason I bought the HP G2. I am 74 and have Macular Degeneration. This makes the center of my FOV cloudy and, in a small area, blind. Unlike most reviews, I find the G2 to be a godsend for my ability to see fine detail. I have no problem moving my head to see because I have to do that in real life, too. This is also why I have worked to get my settings up as high as possible. I turned off Reflections, Light Shafts and Bloom cause they degraded my ability to see my primary visual objectives.

Given @Ianrivsmith has disabled his OXR render scale and has suffered no ill effects, I am going to try that next.


@cymantix how do you manage to take a snapshot of the entire VR Setup Panel in MSFS? I can only capture about half the items. Transcribing everything is a pain!

You may suffer with a 3080 as apparently openXR will reduce your resolution as you don’t have enough Vram. Or so I’ve heard . So just leave it forced to 100 in open xfr. It’s the same thing anyways

What would you expect the result to be if I tried turning it off - may be a good experiment?

The settings you posted are insane for VR. With those exact settings on my watercooled and overclocked 6800XT, I am getting only about 23fps in London.
Could you do me a favor? Could you fly out of EGLL with those settings in let’s say Cessna 152 and see what FPS you’d get at about 2000 ft out of Heathrow heading towards downtown? Clear sky, morning flight. Just want to compare the result more scientifically. Thanks in advance.

Well I would expect the openXR to reduce your resolution down. That’s my understanding of it.

Hi guys… just to add my thoughts:

I have 5950x + 3090 + 64GB 3600MHz RAM running an HP G2…

(if you have a Ryzen, correct RAM speed is important - for the 5000 Ryzen you need 3600 MHz to match the infinity fabric of 1800MHz of your CPU. Be sure to activate it as well via XMP profile in the BIOS)

I have SMT off (BIOS setting); this prevents the virtual core doubling and so you ‘only’ have 16 cores which is more than enough with DirectX12 not being available yet. Apparently this has an impact on performance…

I have the NVIDIA 457.3 driver and have performance set to max power for MSFS in the driver settings as well as 2 VR frames preloaded.

OpenXR is set to 150 with motion projection off and in Game render scaling is set to 70 or 80 depending on the scenery with TAA on and more or less every setting on Ultra or High (except ambient occlusion which costs a lot of power) with level of details set to 200.

This gives me 30-40 FPS almost throughout and things are crisp and clear

Thanks for your settings. Concur, we can attempt to standardize settings based on similar hardware, but there’s always some smoke and mirrors that affect individual systems. Any thoughts on the Nvidia driver?

Definitely stick with 457.30 IMO

Great point about rolling with the default in open xr and setting 100 in sim. I’ll give it a shot when I get the rig and report back. Thanks!