No ATC Freq

#pc Steam

The Issue-

So I created a flight using the internal options. KLAX TO KLAS A320 FBW Stable Latest

loaded and setup power. battery , apu. adirs set and checked the flight plan was showing on screen.
clicked the tower icon to bring up the ATC and both com 1&2 both have freq 0.000 Com 3 not in use.

Trouble shooting -

Removed all mods leaving just the a320 no liveries no nothing.
This time I setup a KSFO to KLAX powered everything checked flight on screen and again 1&2 freq 0.000

So now I removed the a320 and also removed FSUIPC as well. Restarted my pc.

Restarted MSFS and choose the same flight plan KSFO to KLAX this time selected the Cessna 172
powered everything and again went to call atc. same thing.

see Pics

Haven’t submitted to Zendesk


So I just tried again. still with nothing in my community Folder and new flight plan from NZAA to NZKE and same thing only it has freq but no options - clicking the blue bar at the bottom “ground services” just changes that to “go back to clearance” with no list and back "ground services "

Hi,

I am experiencing something similar, but instead of getting only ground, I am getting only “Tune to traffic”.

This is the same at all airports, even if in a flight and I select nearest airport from the ATC panel. Once selected I can then only Tune to traffic, I can no longer tune to tower to request landing clearance.

When on the ground (at the start of a flight) I can not tune to clearance, ground, tower or anything else other than traffic.

Any help would be appreciated.

1 Like

Sadly I was unable to find a solution after spending searching forums etc. seems to be many different unrelated ATC issues all over the place. my fix I’m re installing. sorry I don’t have a fix for you.

One thing that I did note and forgot to mention. When i had this issue the following also was happening. After putting the route in Regardless if I choose IFR High or Low my only approach available was direct and no sids or stars would show up just the airports ICAO . almost like it lost connection with this part.

Finally after spending 6 hours of reinstalling it appears to be back. fingers crossed.

Many airports do not have towers or have closed towers. When you tune to “traffic”, you are using the CTAF frequency that all aircraft on or near the field should be using. You are your own ATC. You have to give yourself “clearance” to land of all conditions are right and there is no interfereing traffic.

If there is no tower, there is no ground. Since you are your own ATC, you are your own “ground control”. Even though you are your own ATC, you are not the ATC for other aircraft.

Clearance delivery is given when the IFR flight plan is filed. You then tune to the CTAF, taxi, and takeoff from whatever runways you choose. ATC control starts after takeoff when you change from the CTAF to ATC. Same thing for the approach. ATC will approve entering the approach and then have you change to the CTAF.

I’m having the exact same issue. But I’ve deleted and reinstalled the sim twice now and still no luck. It is super infuriating. What’s even worse is I can no longer create a flight plan. It just shows not in database on the MCDU. It all just sucks since this update.if

I take it this is on pc. Steam ?
If so make sure after install all folders are gone. completely.
what aircraft and ver are you trying this on?