No G1000 no VFR Map, no digital instrument data on clean new install

Hi everyone,

I’ve spent all morning trying to find a solution, but to no avail.
I’m new to MSFS and since my install on Wednesday, I have the following issue:

  • The VFR Nav Map doesn’t work. It shows a quarter of random content and nothing else
  • The G1000 doesn’t work (and others don’t work either) the screens are all black.
  • Aircraft with PFDs only show XXX instead of any data (speed, altitude…)

I have a fully clean, virgin install, version 1.29.30, bought via steam. I have no peripherals attached. (waiting for the Honeycomb Yoke in the mail) and no mods installed. Therefore, my community folder is empty. The displays and VFR map never worked since the first flight.

I have read about issues with the Working Title G1000 update, but apparently this is mandatory now, and comes with a new install (like mine a few days ago)?

My system is a 13700K with an RTX4080 and I’m running on 1080p now, so this should not be an issue. Everything else works fine and the traditional instruments work flawlessly.

Do you have any ideas where to start troubleshooting? Thanks in advance.

#edit: Forgot to mention I’ve tried both DX11 and DX12 and different settings for Glas Cockpit resfresh rate.

1 Like

Welcome and sorry you have had no replies to help yet.

This is a very strange one. I have not heard or seen of ANY of those 3 issues before.

If it’s a fresh install that is super weird. Two thoughts:

  1. Have you checked in Content Manager if any updates are pending?
  2. What GPU and drivers are you using?

Hey thanks for your reply!

During the week it did run a ‘mandatory Update’ if I remember correctly at startup, and I’ve downloaded some World Updates and the Deluxe Pack yesterday, which didn’t make the situation better or worse.

My GPU is an Asus TUF RTX 4080 OC, not even a week old and its running the latest GameReady driver 527.56. The first few sessions I ran with the previous driver, but it didn’t work with that one either.

I was thinking of reinstalling the whole thing, but since everything else works perfectly well, I don’t see a high likelyhood of that being worth the effort. Is there any tool or method to check the sim is installed properly?

1 Like

Not that I am aware of :frowning:
I don’t think a reinstall will help - but depending on your internet speed you may not have anything to lose with currently a vanilla sim. Could eliminate that as a cause at least!

This sim is a mystery sometimes - when it works it’s glorious but it can have you pulling your hair out too!
Sorry your first experience of it has been instant confusion and frustration!

As I say. I have read a LOT about this sim on here and a few other places whilst trying to get it to run nice on my underpowered system (I have managed it rather successfully), and can’t recall seeing anything like these issues before. It is REALLY strange.

Hopefully someone else will see this topic now it’s had some activity and be able to give another angle to check!

Haha I already asked myself what I got myself into. Tweaking for a few more frames is fun and all, but major functions not working straight out of the box is something I didn’t expect, especially with a state-of-the-art system.

Thanks for your input. I’ll do the reinstall, just to be on the safe side - and will report. Have a safe flight!

1 Like

Okay, in case anyone else will experience this in the future:
A reinstall did it for me. Apparently something got lost during my first install.

Now I have:
Clean new install → VFR MAP & G1000 working (and displays in other a/c such as TBM930)

let’s see what happens when I try updating to that…

Nice!!! So glad it worked… Enjoy :wink:

1 Like