No Instruments in external view after the last update

Does anyone more is experiencing the missing external instruments view after the last update?
I have tried the maximum and minimal options but nothing seems to appear.

Hello @JoshingSoap1550,

Are you referring to the just-released beta build (AAU1, build or the full release of SU11 (build Please let us know.


The full release

Hi @JoshingSoap1550,

I am unable to reproduce your issue. Instruments in external view are working normally for me in build

Have you checked that the setting to make external instruments to be visible in Chase Cam mode didn’t get disabled somehow? You can find this setting by navigating to Options → Assistance Options → Instrument Heads-Up Displahy - Chase Cam as shown in the screenshot below.


Thank you for your assistance…

Yes, the option is in full as yours but nothing happens when I enable it.

: (

Have you tried disabling the options, saving the settings… back into the sim, then back out and change the option back to on then saving?
If I recall correctly there are two external views you can switch to, one supports the external instruments and the other doesn’t I think. I only every use the external view to have a look at my aircraft in flight I have never fly in external view as such and certainly do not want the instruments running the view.

I do use the options as I fly both inside and outside

I am afraid the “enable/disable ritual” doesn´t sound logical for me. Anyway thank you for posting.

Have you tried removing/disabling any mods/addons to confirm none of those are causing this issue?

It is not about the idea being logical it is about seeing if cycling/saving the status would rectify the problem you are experiencing. Assuming you already had the sim running it would probably taken about the same time to try as replying to me. :stuck_out_tongue_winking_eye:

1 Like

I did what you suggest without any results :frowning:

I will try and let you know.

Worth a try all the same.

Definitely not in drone cam mode by mistake? Maybe a double binding?

Double binding?

I have try everything (instead deleting the sim) without any result.

I mean is your external/cockpit camera key somehow also binded to drone cam or something?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.