No Mouse Interaction with Virtual Cockpit


I just updated the game and now I cannot click any buttons or knobs in the virtual cockpit of any aircraft. My yoke controls work, and I am able to select the menus at the top. However, when I try to toggle any switches with the left click of my mouse, it performs no action besides highlight the control that the cursor is hovering over. Anyone have a fix for this? Tried restarting the game and my computer already.



In my case, the mouse profile was set to my custom one from before the update. I just switched it to Default and it worked.


Go to your General Options → Accessibility and under Cockpit interaction, switch it to Legacy. Detailed explanation on the new Cockpit Interaction modes here.


Had the same prob: the obvious way to “move” the buttons by clicking on them doesn’t work anymore !!! Now I found out you have to "click on the button… HOLD the click! (the mouse arrow disappears) and move the now non-visible arrow to the left / right (i.e. the ALT changes if you change the value in this way)… release the CLICK and the button / lever / whatever moves… nonsense!

1 Like

this is not bug this is feature, now mouse need to be focused for working, i ask this long long long time, because, if not, and you use zoom wheel you can accidently switch, rotate, close, open, on, off every freaking thing, i think they could make better, just disable active cursor instead to do it invisible in free view mod.
another variant - msfs is not focused and work background that’s once or twice was for me in very old version(s?)

Since the most recent update I have been unable to click on anything in the cockpit. Anytime I hover over a button with the mouse it highlights in blue but I can’t click/ activate it.

Using Honeycomb Alpha+ Bravo and Logitech rudder pedals

I did have a Xbox controller plugged in but unplugged it because it seemed like the Sim was recognizing it as the primary controller

Go to your settings, and take a look for something called “Cockpit Interaction System” - Set that back to default and see if that solves your issue.

edit: Sorry set it to “Legacy”


Yes, turn off the “Lock” mode to the “Legacy”


Well, thank you. After sifting through all the negativity I was finally able to find out how to solve my problem. I too only gave the release note a cursory glance. It was the new Lock mode that was keeping me from interacting with the cockpit instruments and switches. It just seems to be broken but setting it to legacy put it right again. From where I am looking at it this new feature is a bust. I tried holding down the mouse buttons but nothing I did would work. Maybe it requires an X-Box controller. And that is one thing am am not willing to do.

1 Like

I’m having the same issue. Mouse works in the menus and the cursor moves and hovers over the instruments causing them to light up, but when it says click to interact (left click) nothing happens. On Xbox I cannot change to legacy or lock mode there is no option.


You can always change the zoom mode from Manual to Focus so that you use right click to zoom instead rather than mouse wheel scroll. So that you don’t accidentally zoom in while you’re trying to scroll knobs in the cockpit and vice versa.

nah, i use wheel not only with mouse, but with my left throttle controller, and this is convenient, so i don’t need to change it, and i really need mouse cursor disabled/inactive with it, and i glad to see new system, sure legacy not lock:) and i see zero problems with cursor go inactive, as it go back when you move mouse or mini stick mouse control just a bit… so for me this is one of the best what happens with su5, would be cool next stage - open toolbar with keyboard, not with move cursor to the top, because i think that’s irrational toolbar appearing must be optional only
p.s. devs didn’t fix it complete, when flew husky and zoom, it add altitude to altimeter… unbelievable… what the problem instead make cursor invisible in the free look, make it disabled, as doo billion games makers before asobo, more than year this nonsense bug

Don´t know where to put this… I have two main issues.
First, that “cockpit info” that shows up over every single buttom… how do I remove that? See pic…

Second… I belive it´s due to the first issues, but I can´t do anything with G430 in the Arrow. Nothing happens :frowning:
Please help…

I have switched off legacy mode and yet I am unable to zoom in and out, select switches or click anything on the toolbar.

Not just CLICK… hover over the button (it turns BLUE), click and HOLD IT (it turns YELLOW), than slide (while still holding the click) to the left (decrease) or right (increase) or vice versa. After reaching the desired number / count / digits… let go of the click (button turns blue again) and you can move to the next item.

I have no problem to use the buttons the old way; to the contrary - it’s better! Now I have these “view-blocking descriptions” (how to kill them???) and the handling of the buttons is more time consuming (i.e.: ALT - switching from “managed” to “manual input” is no longer possible. I go back to “legacy”!

I’ve found a somewhat solution for the mouse not clicking in the cockpit. It has to do with the “pilot” camera view that I have set to default. I learned that if I open a checklist and click the view button so the camera pans to that specific switch, I am then able to use the mouse to interact with the switches. Also if you switch to any of the instrument views in the camera drop down menu it will also work.

Same issue not able to look around in cockpit view, if I stay in view to log the screen starts to shake.

Legend cheers brother :+1:t3: