No mre CTD's..... Surprising fix!

Sounds like your GTX was not working properly, the BSOD was a good indicator of that so a good move I would say. Nothing wrong with spending money you can afford to spend to get something better.

Yes, FS2020 is sensitive to high Ram speed and sharp timings.
I dont know why, every other Soft/Bench/Stresstest runs without any problem.

Back in the days of SU 5 things were bad. Really bad, with daily CTD.
Lately, my setup is rock stable. No CTD, no unexpected behavior, everything running perfectly smooth.

FS + many add-ons, now occupying 950 GB on m.2 SSD
I-9-10900K/64GB/2x 2TB m.2 SSD/RTX3090/2nd mortgage :slight_smile:

Welcome to the gang, I’ve just upgraded to a RTX3060 12GB too, though I wasn’t having ctd problems I sure needed the boost coming from a gtx1060 3GB :grinning:

1 Like

I really only get CTD’s when my GPU is overclocked at my usual levels, despite the clocks being 100% stable in other games and during stress testing. So I keep my GPU overclocks pretty mild when running MSFS.

Yeah, same here. With my GTX 790ti with 3 GB VRAM I had fairly regular CTDs. I got into the habit of saving a flight every 30 miles or so.

Then I got my hands on a 3080ti and now no more CTDs, no saving of flights anymore :slight_smile:

There are 3090’s and 6090’s crashing too. It’s not the GPU. It’s programming! I have a 6090 and get crashes every now then.

MSFS Application Error - memory could not be read

Good for you that it got resolved. My PC seem to be fine up to now but after using the Fenix A320 for a week, I started to get a lot of CTD. Places that use to be fine now becoming an issue or even loading the game. Just so ironic. I then uninstalled it but still getting CTD. I sometimes show missing D drive for my community folder or Orbx Central will show no access. Just weird things I have never encounter. LIke having to reboot my PC to just reset everything. I swear I never had to work so hard for a game to just run properly.

It seems to be with only MSFS too. All other games I don’t have this problem. If I haven’t spent so much money on this game I would just call it quits. Oh well might just reinstall everything new form scratch to see it helps.

Try holding the shift key down when you shut down the computer. This will cause it to completely shut down. Then the next time you start the it will be a fresh start. You can also change this in the power settings by turning off Fast Startup.

1 Like

Most problems occur in plug-ins and networks

1 Like

Great suggestion! This is exactly what we need for the climate! Never turn off any electric appliance even when we don’t use them…

yes, total nonsence…

This thread is about preventing CTD.

It works for me, it’s not “nonsence”.


to me is total nonsence keep on my pc only to not have some ctds, also it is on stby anyway. This is hw problem probably. I understand, it’s your money to pay more for electricity.

If I would have to deal with multiple CTD’s for 40 minutes before I can have a smooth flight every time I want to fly would mean that I wouldn’t be able to fly anymore since my “sim window” is about 2 hours a day at the max including flight planning. Is it still nonsense to you?

In a perfect world I would turn my computer off but the sim is not stable in its current state.

Let’s not turn this forum into another toxic political arena. We have lots of real world pilots in here who “destroy” the climate much more than me with my PC on low power settings but it would be ridiculous to criticize people for their flight hobby on a flight sim forum, no?


again, i said non sence to have electricity pending at full W power, no eco harms. Point that eco feelings to proper user who said that. I think he has Expert word in his nick.

Then we agree to disagree. I want to keep flying after work because it’s my hobby and leisure activity.

Fair enough, you didn’t write that about the climate. Maybe he will read it anyway.

1 Like

I dont switch mine off either. It goes into sleep mode every but I never actually switch it off totally unless I am doing some hardware changes on it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.