NO SOUND in VR mode, help please

The sound works fine for all other Oculus Rift apps/games. Wearing the headset and starting FS2020 from the virtual desktop the sound is OK for the start of FS2020, then as soon as I start VR mode the sound goes off?

This happens in both ways starting FS2020, from the real desktop or virtual desktop.

Change the default audio device in windows when running vr. Could be an option in the oculus tools. Don’t own one, don’t know. WMR does it automatically.

I have checked the audio device and have set the Rift Headset as the default audio in the real or virtual desktop. I have contacted Oculus support about this.

image

As mentioned, select your playback device as the Oculus device.

I have, same problem exists.

I am also having this same issue

This problem has now been solved. Before (after PTC update), the Win10 audio setting was set to ‘Headphones (Oculus Virtual Audio Device)’. After the Oculus PTC update, this was set automatically, but did not work? Change this to ‘Headphones (Rift Audio)’. Upon changing this the Audio in VR works fine, at least for me.

Before you start the game, go into WIndows / Control Panel / Sound / Playback, and set your VR headset to “default device”. Weird, but no other way at this time I guess. Putting up in Bug now…