Not able to start MSFS after newest Windows Update

I did update my Windows today and now i can‘t open MSFS. I always get kicked to the "Xbox Game Services“ which i can‘t update no matter what i try. I know other people had a similiar problem but could fix it. But every proposed solution in other threads doesn‘t work.

Hi LifeONEptune

did you try the solution deleting 2 Windows Registry Entries (regedit.exe with Admin privileges)?:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GamingServices]
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GamingServicesNet]
  1. close all apps
  2. delete these two reg entries
  3. reboot your computer
  4. try again to updtae the xbox game services
    → then proceed with the other updates

(i would also check windows update and other optionals, also all available updates for GPU (and Microsoft Store, if you use it)… and AGAIN reboot, before starting MSFS or MSFS update)

2 Likes

This solution worked for me. Don’t think it is a msfs specific problem, but a more general ‘gaming services not surviving a big Windows update’ problem. Microsoft kind of dropped the ball here, spent a full afternoon last week trying to repair my installation before I found this fix somewhere else on this forum.

Try
https://forums.flightsimulator.com/t/solved-msfs-does-not-start-microsoft-store-error-code-0x80073d26/406876/5

1 Like

That did fix it :smile: Thank you :facepunch:

1 Like

Closing as solved by OP.