NVIDIA GeForce Game Ready Driver 536.99 Discussion

Please use this thread to discuss the NVIDIA GeForce Game Ready Driver version 536.99.


Game Ready for Baldur’s Gate 3

This new Game Ready Driver provides the best gaming experience for the latest new games supporting DLSS 2 technology including Baldur’s Gate 3, The Texas Chain Saw Massacre, and Gord.

Fixed Issues

Fixed Gaming Bugs

  • [Control][DX12] Cut scenes and videos show tearing and partial jitter [4084000]
  • [Battlefield 2042] Game stability can decrease when applying GeForce Experience Freestyle filters. [4170804]
  • [GeForce Experience] Game stability can decrease when applying a GeForce Experience Freestyle filter in certain games while using DLSS 3 Frame Generation [4171660]
  • [Dead Space] Game stability issues [4140545]

Fixed General Bugs

  • [Elgato Wave Link] Potential audio issues with NVIDIA Broadcast effects [3752618]

Known Issues

  • [Halo Infinite] Significant performance drop is observed on Maxwell-based GPUs. [4052711]
  • [DaVinci Resolve] This driver implements a fix for creative application stability issues seen during heavy memory usage. We’ve observed some situations where this fix has resulted in performance degradation when running DaVinci Resolve. This will be addressed in an upcoming driver release. [4172676]

Ill update later in the weekend, no benefits running latest if current is good :ok_hand::heart_hands:

Apparently fixed. As ever, not confident but will give it a try.

Well, I have just had a fly around for about an hour. FG on, Filters on. No crash. The last driver was crashing within seconds for me if I had Filters on.

Good start but need more testing.

1 Like

I need this for the wonderful Baldur’s Gate 3, so going in. WMR VR with 3080Ti, will report back.

EDIT: VR DX12 with DLSS, seems all good. Upgraded from 536.23.


Could it be finally fixed??? (Nvidia Filters no longer crash MSFS on DX12/Frame Gen??)

Everyone – I am HAPPY TO REPORT that Nvidia Filters and the latest Nvidia Driver have NOT crashed my sim and I’m on 4 hours so far into my flight. I have a 4090, 32gb RAM DDR5, 4k HDR and haven’t been able to use a recent Nvidia driver in months due to this CTD w/ Nvidia Filters issue.

For those fellow 4090 users, I AM on Frame Generation, TAA, DX12 and it’s working great with my Nvidia Filters:


Awesome news, thanks for confirming. Update time!


I’d take it that reshade is still incompatible though with FG though, right?

Don’t suppose the new driver has allowed VSYNC to work with FG?

1 Like

Here is the CLEAN version of the driver from Guru3D.

I will install the new driver, unfortunately I cannot run MSFS without a CTD and PC keeps on abruptly shutting down. I feel as if I have a mountain to climb of PC problems…


Have you check your Power supply unit?

Care to share your filter settings?

Hi, SanMan, no yet. I had a warning PC is low on memory. I am going to take the PC back to Wired2Fire. I think it’s an error with the PC that is causing the simulator to crash. Anyhow, perhaps you or anyone could PM me if you have ideas on a fix. To avoid going off topic. I have just managed a Windows 11 update which had a dotnet fix 3.5.



Perfect, finally. Does anyone know a good resource for GeForce Experience filter settings? I watched some YT vids, but those shown there are all not really to my liking…

What are your Pc specs?

I installed this new driver and left the driver at default settings, selected low graphics settings within MSFS and I can now fly without a sudden CTD! :grin: I was close to a full reinstall! I flew from my new CYYC Airport which I bought in the Market Place sale. I experienced buttery smooth performance, I quite like this low graphics settings. I have not been able to really try the airport out because of the CTD’s.

AMD Ryzen 5600X. MSI B550 A Pro. MSI G-Farce 1070 GPU. 64 GB RAM. Asus Xonar Sound Card. The 1070 is holding up well! It might be the GPU that is causing the sudden abrupt close down of my PC. I did not get any warning of low system memory this time when the simulator finally decided to behave itself.

Yours aye.


I didn’t know this. Can you confirm this please? Reshade causes frame gen NOT to work? Looks like I need to dump Reshade.

Well filters and settings are very much a personal thing. There’s no ideal settings so it is pretty much trial and error. I usually use Colourfulness and Details.

IIRC they are actually Reshade filters that can be added to nVidia Freestyle Filters. They are part of the Curated Reshade Filters pack. Install them into your Ansel folder and they will appear in Freestyle like all of the others.

Info on here : New Game Ready Driver Released: Includes Support For GeForce GTX 1660 SUPER; Adds ReShade Filters To GeForce Experience, Image Sharpening To NVIDIA Control Panel, G-SYNC To Ultra Low-Latency Rendering; and Support For 7 New G-SYNC Compatible Gaming Monitors | GeForce News | NVIDIA

I also use an RTX 4090 and HDR, but would like to try out an Nvidia filter again, could you please be so kind as to post your filter settings…thank you!