NVIDIA GeForce Game Ready Driver 545.84 Discussion

Please use this thread to discuss the NVIDIA GeForce Game Ready Driver version 545.84

Download GeForce Game Ready Driver | 545.84 | Windows 10 64-bit, Windows 11 | NVIDIA

Release notes:

Game Ready for NARAKA: BLADEPOINT and Warhammer: Vermintide 2

This new Game Ready Driver provides the best gaming experience for the latest new games supporting DLSS 3 technology including NARAKA: BLADEPOINT and Warhammer: Vermintide 2. Additionally, this Game Ready Driver introduces TensorRT acceleration for Stable Diffusion to increase performance by up to 2x.

Gaming Technology

  • Introduces support for RTX Video Super Resolution v1.5

Fixed General Bugs

  • Some monitors may display random black screen flicker when in Display Stream Compression mode [4034096]
  • Monitor colors are incorrect after coming back from display sleep [3420257]

NVIDIA Release Notes pdf


Hey…where’s my ‘clean-version’ Charles… :open_mouth: your late…
Just kidding :rofl:.
You provided us with enough information to create a clean version ourselves. So instead of being lazy, I’ll get to work this time.
Kind Regards :wink:,

1 Like

This new driver is perfect for me. It looks great!

RTX4070ti +5800X3D

After some problems, it does work for me, 4090

I was able to make it work 30mhz higher at the same voltage, vs the previous one. I need more testing, but seems to be good.

Been running since release, no issues at all. (HAGS on, 4090 in DX11).

1 Like

So far so good running PCVR with both my QPro and Q3 using Air Link. Win11/i913900k/rtx4090 and DX11 with HAGS = off (smoother in VR, for me anyway).

So far so good - stutter free.
4090 + i9 13900K - ultra, TAA 2K

1 Like

TensorRT is mentioned. Is this applicable to the sim?

According to what I read online…

Internet connectivity during installation
NVIDIA Studio Driver 537.58, Game Ready Driver 537.58, NVIDIA RTX Enterprise Driver 537.58, and above

This extension enables the best performance on NVIDIA RTX GPUs for Stable Diffusion with TensorRT. You need to install the extension and generate optimized engines before using the extension.

I’m guessing it’s not, since Stable Diffusion is a machine-learning technology. But you never know until you know.

I uspcaled my primary resolution to 4416x2484(4k +15%), so that when I use DLSS+Quality the resolution increases in the same proportion. TOD 235 OLD 500 via Cfg. It looks great.


OLD 500 manually in config (200 is max in settings). interesting… i will try it

Why 235 instead of 205 or 255 Tlod?

I once saw a user here on the forum who made a projection of how many FPS that each increment of 5 in 5 the TOD consumed in FPS. For me, the limit found for a better balance of my system was 235… With 250 I was already receiving sttutters. Yes, in CFG you can change the loading of objects above the default(200) so that you are not loading objects as you move through the simulator. This way I realized that it already loads nearby objects faster and in advance, which helps with MSFS performance. I use the shadow generated by the aircraft panel in 8k (8192) also adjusted in CFG… the shadow is very well defined. This tip is also valid… for me with no impact on FPS.



Thank you for the tips. I will try them all

Is your memory gear 1? i have no stutters since i run gear 1. I believe this driver allows some more overclocking at the same volts

i see 2 shadows, shadows and heightfield,

both at 8k?

No. Only shadows. Type 8192.

See this: Better Shadows

and in the Menu options you will see 8192. However, do not touch the arrows otherwise it will return to the maximum which is 4096.


1 Like

thank you!

Where do you download the necessary extension to run ‘Stable Diffusion with TensorRT’ for the Nvidia 545.84 driver?
Or have I misunderstood something?

545.84 worked fine performance and graphics quality wise on my system but it broke GPU temperature monitoring in Argus Monitor so it’s back to the previous driver for me.


So I tried OLOD at 500 and started getting CTDs at large airports like KLAX. So be careful with this setting.

Edit and I’m on a decent system, i13900k/4090/64gb/NVMe

1 Like

How to do this please?

Via NVCP. I create a custom resolution (proportional)