Nvidia NIS did you try it out yet?

it does, i tested it on my 21:9 38 inch ultrawide.
but it’s bad tbh, in-sim render scaling is better than nvidia NIS.

DLSS would be better

I do not see the advantage of doing this.
Finally you display your sim at a lower resolution than the native one of your monitor
As a consequence, you have a boost in framerates.
But the object of NIS is to upscale a lower résolution in game to the native resolution of the monitor.
And in your process, this is not the case.

What is this? Its like ReShade?

Yes. But thats actualy the benefit of this new Nvidia upscaling method (Google for it). The image scaling does a nice job to upscale this lower (desktop)image to the native resolution of the Monitor. The image is much better and displays on the native full monitor scale. Also the NIS scaling gives som extra scaling resolutions too choose from for your desktop.
Because MSFS is a borlerless window that’s the only way its works. There are tips elsewhere on this forum to use a MSFS full screen (edit the config.opt file) but that doesn’t work for me.
So the MSFS image is with image scaling much clearer as on native lower resolution.
Try it out!.

Hm, strange. Never worked for me or it ended on CTD after loading a flight…

Also check this out,
works awesome

1 Like

I tried it out on my 4k monitor and was able to gain 10 or so FPS without being able to notice a drop in IMAGE quality. I only went with a 20% sharpening as this was recommended for 4k.

Can’t wait to try it once they fix the latest gpu driver.
Id actually argue it looks slightly better with NIS.


I do not understand how this works…
Is it possible to have a clear explanation?
The description in github is also not clear…

Its simple a (program overlay) dll that uses Nvidia upscaling method (NIS) also for VR. NIS works normal only on a normal (not widescreen) monitor but gives a great FPS boost. I got in VR from 19 FPS to 25FPS. Ofcourse DLSS method is better but this also dont work on VR (and so far not useable in MSFS). It is possible in VR but much more effort is needed. Mabe somebody (or #Asobo?) gives it a try?

NIS is also much better then the scaling method in OpenXR tools or the scaling in MSFS itself.
Also this tool is (for now) only usefull for WMR VR. But the author is working on a Steam VR method.

Yes it is a bit technical but “Google is your friend”.
If you have a WMR VR headset try it out.
Also try the standaard NIS on your desktop (it is free in the newest Nvidia drivers) . This gives a nice frameboost on your monitor and is also very usefull.

it works on 21:9 aspect ratio resolutions as well, i can confirm this

After looking at a video on youtube I could get it working.
I tried an upscale from a resolution of 77% from my native 1440.
Yes this is ok, I gain some FPS, but the general feeling in the cockpit is that the
Instruments are more blurry despite a sharpening of 30%.
But interesting nevertheless.

yeah it can’t hold a candle to native, while DLSS sometimes even does better than native in some cases.
NIS is allright for really low-end GPU bound cases when there is no FSR or DLSS available.
But Asobo’s in-sim render scaling is better than NIS

1 Like

guess it does wonders for VR users, on a monitor it’s not that great tbh.

1 Like

See my screenshot few posts up, works fine for me on a 4k monitor and because of the increase in fps also able to turn some other settings up.

it works but it’s nowhere near native like fsr/dlss

Iv been trying to shut anything Nvidia down, since i read, Nvidia container was running x3, and was using 30% of my cpu, no wonder msfs was taking ages to boot up, i have Nvidia GForce 970, only just inside min spec, but iv stopped Nvidia dictating when to up grade, they have to much running in the back ground…dont take my word…google it, you,ll be amazed,

I can’t seem to get it to work with MSFS. It works with FSX though. I followed the instructions and the NIS in the upper left was in blue when the sim started up and was supposed to change to green when the in sim resolution settings are turned down, supposedly meaning the image scaling was working to upscale back to the native resolution (1080p for me), but when I do that instead of the NIS turning green it just disappears completely and I don’t know why. If I set the resolution back to the native 1080p the NIS reappears in blue. As I said it works in FSX. Anybody have any ideas?

I have to set it my resolution lower in my desktop display settings or in nvidia control panel for NIS to work in MSFS. Nis works fine in other games when setting resolution in game.

I then set msfs in sim res to match the desktop. your scaling on desktop will make everything larger so then if you go to your display setting set the zoom level lower.

1 Like

Im confused about how this works.

I have enabled NIS, with the overlay at 77% and sharpen at 20%.

So MSFS needs to be in fullscreen at native desktop resolution? And ingame render scaling set to 100?

I am only seeing the blue NIS symbol for sharpening and never goes green and scales the display. What am i missing?

The only way to get the scaling on is to change the scaling on the nvidia control panel under resolution, but that changes the desktop resolution too and i cant use it because it always reverts to 100hz and i only have a 60hz HDMI connection so the screen goes black and i have to reboot. Even when specifying 60 hz it reverts imediatley

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.