Object not appearing in scenery editor

So I’ve been trying to bring a model from blender/3ds Max to msfs and I exactly followed these videos: [003] Adding User Created Scenery - Microsoft Flight Simulator 2020 SDK Tutorials - YouTube How to add Blender Models to MS Flight Simulator 2020 and place them in a scene (MSFS Part1). - YouTube MSFS SDK Tutorial - How to convert model for inclusion into the sim. - YouTube but for some reason after doing everything my object doesn’t appear in the scenery editor.

1 Like

You‘re not alone. Same issue and many others too. No idea to find a solution. Tried to implement the sample scenery, No success. But I‘ll try to remove all 3rd party addons in the community folder and try again…

Any advice / solution is very appreciated. Spent hours of hours… :unamused:

1 Like

After this World Update 4 you can forget following youtube tutorials, since Asobo must have changed something extremely, so that the workflow of the last few month since the release of MSFS doesn’t work no more - so all the tutorials online are basicly obsolete …
You can only view your creations, if you build the package blind - quit MSFS - copy the created package into the community folder (like it would be a already finished addon) … restart MSFS , back in the scenery, loading your project with the project editor and load the bgl-scene - then your stuff will appear (but only if it was done right without errors) in the objects window list … It’s ridiculous now, because if i just want to check like a color change say from red to green, i have to build a package, place it in the community folder and restart MSFS.
That is no productive workflow no more - like it was all the time - that’s just a pain in the a** …

1 Like

it’s not a feature it’s a bug

I am on the same plane…there is a BUG on the module scenery creation, the compiled model doesn’t show up in the list and I know it should be there for sure because is the same script I am using since months… even the sample scenery doesn’t work… :rage:

1 Like

There is this virutal file system and the package listing available to call up in the devs mode - and if you don’t place the created package into the community folder and run the sim from start, the created or worked on project won’t appear in the list as a “mounted” package, it shows as “unmounted” … it’s then unmounted and you won’t be able to see anything from your project at that time.
It seems to me, that all this is a preparation for the near future release of the MSFS on the XBOX, to have a cleaned up file system working - because a XBOX is a gaming console and doesn’t or shouldn’t allow wild modding stuff … just guessing …

1 Like

Having the same issue. I was using the same workflow then before, so THEORETICALLY it should work. But now, no new models can be added, because they don´t show in the objects and the already existent objects are not present under “scenery” as well. At least the models I added previously are still there, they are just not findable in objects and their name is displayed as unknown. Maybe I should be thankful, that Asobo did leave the “old” models…

But what the hell is that sh****. I am doing this in my free time, and after every major update there is a silly bug, that keeps me from getting forward and makes me going crazy for hours, until hopefully some random people come up with an idea…
This is not fun anymore!!!

3 Likes

After hours of trying to figure what was going on, here what I did to be able to see my objects and to import them again.
So there are 2 issues preventing us to work. The first one, objects appear invisible and are marked as unknown. If updating the SDK did not fix it, build the package and place it in the community folder, the object will be build regardless of the error, and once in the community folder, it will be visible again in the project. The second problem is, if you tried to import your converted model from Blender after the update, you have probably problems seeing it in the SDK. Following the regular steps we all did till now to have them imported in the sim, does not work. The way to fix this is the following: build the project first, do not load it but instead restart MSFS, reopen the project but this time DON’T build the project, just load it. Your object will be there. But now there is a new issue (for some maybe is not) your objects will now be shared among all your projects, as long as your project has a package build in the Package folder, you don’t build it but just load it, and as long as you don’t close the SIM.
Hope that someone will find this post helpful.

2 Likes

Having the same issue here. I’m the guy that did the reno stead scenery. All of my models are gone. They are no longer there, and they don’t show up under scenery. I updated the SDK, used the same workflow from before and everything is gone. I will report back if I find a workaround.

1 Like

read my preview post.

Excellent, thanks. This is the way, look at JackSpidaargh’s post.

1 Like

After doing what you said, on the 5th attempted it finally worked thank you so much!

1 Like

Yesterday, I put this issue in the 1st SDK chat with Asobo/MS. They didn‘t recognize the problem.

I will check again: docs.flightsimulator.com to build a custom scenery from scratch (create new project in MSFS) instead of replacing datas in the simple scenery folder…

Whenever I had this problem, it was because of an texture size mismatch. You must make sure that the size is allways something like 256x256 or 128x256 (it works also with 512,1024,2048,4096, etc…) the error message in the console is not very helpful, but if you don’t keep it that way, your object will never show up in the Scenery Object selector. Hope that helps :wink:

What is have I done wrong over the last week since I last used the SDK??
I am currently having issues where I open a airport that I have been working on and the default scenery I have been using is coming up as “Loading” and everything is blank in the objects scenery page as in nothing appears…
What have I done for this to happen… I now get freezes and CTD every time I try build a scenery.
This was something very similar that happened a number of months ago and for the life of me I cant remember what I did to fix it and why it is now happening again…

This business of needing to have something in the Community folder in order to create something that goes in the community folder has always seemed backwards to me.