Oculus Quest 2 Setup Guide?

Good afternoon forum,

I have searched for how to setup / best settings for the Oculus Quest 2 but there is quite a bit of conflicting information.

Kids got one for Christmas, along with the link cable and wanted to see what MSFS looked like in VR.

Does anyone have a reference they use with how it should be setup?

MSFS is also Steam version.

Thanks.

Hi,

For sure, there’s quite a bit of information out there like you say, I think it ultimately depends on the specs of your PC. I found this video from Pie in the Sky Tours on youtube to be a great starting point.

Ultimately, I settled on the following config (I have i7-10700K, 32GB RAM, RTX 3070, and Quest 2):

  • Link cable
  • 80Hz at 1.1 resolution in Oculus (i.e., 4224 x 2128)
  • In-game resolution set at 100, most settings on high.
  • I also use the Oculus Tray Tool. Default Super Sampling at 1.0, and Mirror FOV at 0.83 & 0.83

This last setting, FOV limitation, was initially a non-starter for me. However, it definitely makes a huge improvement to performance. If you think about the maths, rendering at 1 x 1 resolution = 1.0, or 100%. Shrinking the FOV to say, 0.8 x 0.8 = 0.64, or 64%. That’s a 36% improvement. I also discovered I actually prefer to use the glasses spacer with my Quest 2, even though I don’t wear glasses. I find I just seem to get better eye relief. Anyway, turns out that having a smaller FOV isn’t an issue because I can’t see any difference when using the spacer.

I get great graphics, audio, and performance with this setup. I only fly in VR and I love it.
My MSFS is also the Steam version, however, I use the Oculus VR platform, not Steam.

Cheers,

3 Likes

Hi thanks for the tips.

What about link presets ? with encode resolution and bitrate ?

Encode Resolution i have 3648 and bitrate (Mbps) iv always left mine at 0, I leave it at 0 Default as it helps when flying with Oculus Airlink…Test it tho some people set it to 300…I dont see any diffrence tho using Link keeping it default or setting it to 300

I also have the encode resolution set at 3648.

If you use Airlink, even occasionally, it needs the bitrate to stay on 0. Anything else and it lags really bad. Overall, I prefer to use the link cable with MSFS and I bump the bitrate up to 500. From a graphics perspective, I noticed a difference for me, everything is clearer and crisper when it’s set higher. I also noticed an improvement between 0 and 300. Tiny details on runways are clearer and some of the compression artifacts seem to disappear.

I also get more stable results when increasing the bitrate in the Oculus Tray Tool. I was noticing if I increased it via the debug tool my audio might stutter occasionally. I know they essentially do one and the same, but it’s just my experience.

Cheers,

1 Like

Thanks to both of you.
I tried both airlink and cable, i also had to put the bitrate at 0 with airlink or it was lagging too much. However it seems the image quality is less crisp with airlink than with Cable.

And it’s even worse with VirtualDesktop, you can’t set anything with Steamvr nor with VD. It looks to me that this VD hype was a scam…
I wish OpenXR could be usable with Oculus, so we could use NIS. Unfortunatly NIS does not recognize the Oculus openxr .json.

I will try to lower my graphic resolution in oculus app, i was at 90hz and maxxed out ( 1.7x if i remember )
You don’t use sharpening in Quest Link ? below bitrate

i have openxr with oculus quest 2 and nis scaler and Scharping

Sounds like you’re making some progress so that’s good.
Yes, I have link sharpening enabled when I use the cable. It also works well with AirLink.

RE: Virtual Desktop - just confirming that you’re using the version from the Quest 2 app store? If you are, you should be able to adjust the graphics settings. As a quick guide - after you enable the desktop streamer service, launch the VD app from within the Quest 2 headset itself. Once it opens you should see the main menu appear, with tabs on the left-hand side for items such as - Computer, Environments, Games, Input, Settings etc. Under the Streaming tab there are options to change the resolution (e.g. medium or high; and corresponding examples of the type of graphics card you might be using with each setting). There is also an option to change bitrate and whether you want to enable space warp etc. You can also adjust the gamma in their too which may help to reduce the world brightness when in VR. Once you’re happy, start the game via your desktop icon, and plan your flight. You can then load SteamVR, and activate the VR session.

RE: NIS - you’re in luck. A great contributor to the MSFS community recently built a version of this tool that is compatible with VR. I’ve used it before with my Quest 2. Whilst I don’t use it currently, only because I’m happy with the results I’m achieving without it, many people are achieving great results with it and it is also useful for people who may be looking for additional optimisations. Here’s the link to the NIS thread, the software download instructions should be listed at the top of the page.

Cheers,

How did you manage to make it work ? only oculus_openxr_64.json is working in the regedit for the helmet to be recognized in OpenXR, if i use OpenXr runtime, the Quest is not recognized.

Thanks for all the tips !
Yes i bought VD from Quest store, enabled dev mode with sidequest etc…

However when using oculus_openxr_64.json and NIS, the resolution recognized by NIS is very low ( 1400 something ) it’s not what i have set in OpenXR ( i am at 200% or 300% in openxr and i can’t find where to max resolution so NIS can recognize it and sharpen it ).

No worries, you may be having issues because the OpenXR developer tool doesn’t recognise Oculus headsets, which may be why your changes aren’t working for you.

As I understand it, try this approach instead - use the Oculus Link Cable or AirLink to connect to your PC like you normally would. Once connected you should see your Windows desktop. From there, go into the Oculus application (i.e., the app that has the store, game library etc). Go to device, and then see what refresh rate and resolution settings are enabled (it might say 80Hz and 1.1 for example). Take specific note of the number associated with headset resolution (e.g., 4224 x 2128).

Whilst you’re in the Oculus app, be sure to activate Oculus as the default openxr runtime, if it’s not already enabled. You can do this under settings, general, if I remember correctly.

Then, open the NIS tool that you downloaded. If it’s set at 80% scale (i.e. 0.8), the end output resolution in your headset will be 0.8 x (4224 x 2128). This equals approx. 3379 x 1702, assuming your in-game resolution is set at 100%. It’s best to leave the in-game resolution at 100%.

In a nutshell, the game will then run at 3379 x 1702 resolution, meaning it requires less processing power. The NIS scaling tool and the OS then upscale this resolution on the fly and displays it in your headset at the original resolution you set (i.e., 4224 x 2128). Obviously, some of those pixels will be smeared or blurry due to the upscaling procedure, hence the option to apply a level of sharpening you desire.

If your in-game resolution is less than 100, it will also be a multiplier in the equation, causing a further reduction in the final resolution which is not really ideal.

Hope that helps?

Hello, thanks for this.
Look below, the resolution NIS gives me doesn’t match the one occulus app has. Also NIS says it sees OpenXR resolution, but OpenXR is not the active Runtime. :slight_smile:
Shall i ignore this ? It lowers my resolution

And with VD, and Steamvr runtime, it seems to be “half” working. As OpenXr gives me an error message but NIS recognize the resolution And i have to be inside SteamVR Home to see the desktop and MSFS to recognize VR session. For that the order of launch is : SteamVR, VD, Nis, MSFS.

RE: Oculus. The NIS tool appears to be working correctly. At the top-left corner of the NIS window, do you see where it says OpenXR resolution: 2112 x 2144?

  • 2112 is half of 4224. I’m not sure why, but the NIS tool measures the horizontal resolution per eye. When you set your original Oculus resolution at 4224 x 2128, it’s like setting two little screens each with a resolution of 2112 x 2128.
  • Regarding the vertical resolution, 2144, why doesn’t this match the number we set as 2128? Well, it’s actually pretty close, it’s only a few pixels out. I don’t know the technical reason sorry, however, the discrepancy is fairly normal and may be due to different types of computer code in use behind the scenes when communicating with different devices.
  • If you’re happy with the performance gain when using NIS and you like the way the game looks, then yes stick with it.

RE: Steam and VD.

  • I may be wrong, but I’m fairly certain the OpenXR developer tool won’t work with an Oculus headset, regardless of how you connect it (Steam or Oculus).
  • The resolution in your NIS screenshot (i.e., 3292 x 3408) may be coming from the VD app. It does seem unusually high though. Did you enable Ultra in the streaming section? If so, that may explain the high resolution.
  • You may also want to check your SteamVR settings, it’s possible one or more of those is set at 150%. If it is, that’s possibly contributing to the high-resolution number of 3292 x 3408.

Cheers,

The NIS scaler works with whatever headset that is using OpenXR - all headsets that are being used with MSFS 2020.