Oculus Touch cockpit interaction still not working

I’m using the Oculus Touch controllers with Oculus Quest 2, and have never been able to interact with the cockpit since that feature was added. I can control the yoke and, as of the last update, can interact with the toolbar, but nothing else. Controls will highlight when I’m close to them (or point at them in raycast mode), but that’s it.

I’ve seen others were able to fix this problem by changing Cockpit Interaction System from Legacy to Lock, but mine was already set to that from the start, and doesn’t work in either mode.

Any ideas?

I have the same problem! Is there really no solution?

What airplane do you use? I know third party ones doesn’t work much. I’m thinking they need some ekstra data that planes made without touch in mind doesn’t have.

Just default airplanes, I haven’t bought any others. I’ve tried multiple, so it doesn’t appear to be airplane-specific…unless the default ones are already known not to all support VR, and I’ve been unlucky enough to only have tested those that don’t.

The only ones I can remember trying for sure are the Icon A5 and the new Volocopter. I know there were others, but off the top of my head I couldn’t tell you which.

I have tried many standard aircraft!
The yoke control stick works, but buttons and knobs do not work!