Oculus v26 flickering/white flashes

Yes sadly the beta change has been released and you cannot stop the Oculus update, so for Oculus headsets Virtual Desktop is the only option now, unless they fix the flashing. So if you are thinking of buying a Quest 2 do not bother buying a link cable, go straight to Virtual Desktop

Same here! Why did this make it to the release!?!?!? It was reported here, and by a few of us directly to Oculus, but they still go ahead and release the Beta as stable. Unbelievable.

Yes I had the flashing worse than it ever was before and sound crackling-after the updates it was intolerable! So I went with wireless, using Virtual Desktop and SteamXR instead of OculusXr (I have MStore version of MFS 2020)
-No more flashes,clear smooth flying,excellent detail with low specs and sound pumped through head phones,I can hear every subtle change in the prop or jet engine.

1 Like

Might be the way forward then using virtual desktop. So bloody annoying releasing v26 with this issue. Never tried VD, hope it’s easy to get it to work.

What is SteamXR and OculusXr? are they the equivalent of OTT and ODT? I never tried Wireless method before, do you have the link for these 2 apps? I have the steam version of MF.

Here is the link to what I did to get it working using Virtual desktop.

Just after posting this MS store stopped me from playing “Mandatory Update” anyone else? 1.3 GB update only through the store version. Not MSFS auto update? Will see what effect it has.

I had a MF steam update yesterday around 250-350mb, that’s about it.

A quick question, can anyone confirm if the flickering happens also when using the Official Oculus Link Cable? I’m using a 3rd party cable which seems to work flawlessly on other steam vr games.

Hi yes, Oculus just forced the 26.0 update and i am back to the same issue i had with the 26 Beta version before opting out. The Sim is now unusable. Can i suggest everyone with this issue raise a support ticket with Oculus to see if we can get something resolved, or get a rollback option. I have just raised a ticket explaining this is directly linked to 26.0, it only effect MSFS2020 and it is making the Sim unusable for all of us not just one user of the Rift S / Quest.

1 Like

My dudes, I wrote some instruction of how I get awesome performance with the mfs2020 in vr, and there’s part how to revert to v24 (as it’s huge change in perfomance between v25 …) and how to keep oculus from force update. Enjoy.


I will try this, this evening, do you have the link for v25 by any chance?

We have several threads from the same issues, you should use the search function :wink:

Watch a video I just posted on one of the other thread showing the issue (not a fix):

Just checked only the v24 above. But it’s the best one I found… So would not bother with v25, despite flashing there was also hit on perfomance that I’ve noticed.

1 Like

You’re a total legend! all working again with great FPS and no Oculus flashing issues. Thanks!

1 Like

Glad to hear it and glad I could help. You are welcome. :slight_smile:

Is this strictly for quest 2, or for rift s also. If it works for the rift s, and you were a woman, and I had permission, of course, I’d kiss ya! :slight_smile:

I’m pretty sure it works for both : ) as rift uses same oculus software, debug tool etc. Actually know one rift user that used that solution and also wants to kiss me so I guess it works. Try it and let me know. : )

1 Like

what did you do? revert to v24?

No white flashes for me on the Rift S. I followed the instructions you posted, skipping the section on the quest link option. I also wasn’t able to find the Graphics Preferences option, so it’s probably just quest 2. It works great, thank you very much.

I was hoping it would fix the terrain skipping as well, but it didn’t. I get nice smooth graphics when I turn my head around in vr, and the terrain at a distance looks fine, but looking at the closer stuff out the left window of a GA aircraft, the land doesn’t move by smoothly, it skips. I haven’t figured out how to fix that yet.

1 Like

Glad it helped. As the skipping goes have no idea how to help that. Maybe it’s perfomance problem? did you try to change fov to 0,7/0,7 in ott or oculus debug tool? that give some extra performance but has to be done every startup (easier with ott, one click). Also asw 18hz? another big one.

1 Like