Quest 2 Virtual Desktop + Wireless =Smooth flights/no flashes no stutters

After 8 weeks of bad performance, I tried Virtual Desktop again, since it had a recent update.
I also have recently acquired a second hand old wireless router (Nighthawk AC1900 D7000) which gave me 5Ghz.
The router is two rooms away connected to a 2.4 Ghz standard Aussie NBN router- with 40MBps down and 12MBps up.
With these low specs I finally have had the best MSFS 2020 VR experience. (repeatedly)
NO Flashes,very rare stutters and clear buildings with clouds on medium.
Acer Nitro i5 8GB ram and Nvidia RTX 2060 (6GB vram)
-Remove Oculus open XR runtime from registry if there- replace with Steam open XR (steam will do this for you) in Steam VR settings/developer OpenXR runtime STEAM.

Disconnect link cable

1- put on Oculus Quest 2 HMD-Launch Virtual Desktop from your Apps. Wait for it to connect.
2- Launch steamVR home -wait for it to show you the Steam home room in VR. Push Left oculus controller menu button to bring up Steam’s menu.
3-Touch Desktop button on this- you will then see your desktop.
4- Launch MSFS 2020 either from your steam library or where ever you normally do.
5- Steam may shake but will settle down.
6 -Peak under Oculus HMD at your now loaded MSFS 2020 screen and use mouse to pick your country town/ airport for departure PUSH FLY then READY to FLY
7 -Let AI pilot take off.
8 -Once airborne push CNTRL TAB to enter VR -steam will say “Now loading MS 2020 or similar”
(you may appear sitting on top of plane, wait for PUSH SPACE BAR this will center you in cockpit.)
*there maybe slight shudders as VR adjusts…this will settle.
9 -You can now disengage AI pilot (if mouse arrow doesn’t show click left or right mouse button.)
10 Enjoy!
This was all done in a Cessna 152- have not tried other planes or larger aircraft.

You can put the link cable back in if you wish (oculus will interrupt with Enable link cable) which you can do.
At this stage I cannot confirm link cable does anything other than keep your head set HMD charged.
So it appears to be a wireless experience ,but a good one, hope it helps you have good flights!

EDIT: make sure Streamer App is also running Virtual desktop needs this. I am not using any tweaks or Oculus tray tool or Debug tool MSFS 2020 VR settings are almost default except for Medium on Volumetric clouds.
If you have MS store version do not add to your steam library XBOX will deny you access-so I have removed the instructions of how to add MSFS to your steam library.


PS FWIW, I did mine before I saw this post and did in fact use UWPHook to add MSFS to my Steam Library even though I have the store version and didn’t get any access error.

Did you notice a difference running from steam vs oculus?

It happened to me after 3 times loading from Steam.

I’m going to give it another shot, but on the first pass, I’d have to say in my case the steam version was jittery-er.

Yes,It will jitter while steam waits for MSFS to load and start and maybe a bit as you start VR, but should settle, too quick head movements may cause lag.

Some screen shots on my 45 min flight today from YBCG (Gold Coast) to YBOA (Boonah) Started in Cessna 152 changed to Cessna Citation. (all with wireless+,SteamVR) Bumped up Buildings to Medium - Captured with Gadwin printscreen,cropped one side later

Thank you for sharing! What are your Video Settings in SteamVR?

Steam Video settings
Refresh rate 72
render resolution-auto
per eye 2040x2072 98%
Fade to grid on app hang
Advanced supesampling-On
overlay render quality-High

Thank you, I‘ll give it a try!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.