Old thrust reverse system

Can we please, for the love of dear god almighty, get the old (Pre update 7) thrust reverse system back.
At the very least, an option of whether you want to use the old throttle system or the new one.

The new system, where, I think throttle all the way back is full reverse, but then somewhere in the middle it idles and… You don’t need the button anymore for thrust reversers maybe? IS CONFUSING TO NO END!

Wheras, the old system, was so nice and simple and worked so well. Throttle works normal, press a button, now throttle is in reverse. Easy.

Please please please bring that system back. I’m gonna f-ing rage if I have to make another go-around because I can’t figure out how to use the thrust reversers…

What aircraft are you referring to?
To the best of my knowledge, nothing has changed (except for the throttle to throttle1 issue).
It hasn’t in my sim anyway.

1 Like

All of them in my case. But that’s really weird. I’ve already reset all controls and redone all the inputs, I’ve fully re-installed the sim while also manually deleting everything from the community folders, appdata, etc. Problem still remains.

So, for me it used to be that, physical throttle 0-100% matched the sim throttle, and then if I pressed the reverse button, 0-100% on the physical throttle would become 0-100% reverse thrust.

These days, and I’m still not 100% sure on this because it’s not completely clear to me, reverse already starts around 0-10% on the physical throttle, where 0% is max thrust reverse and then up to about 50% is full reverse thrust. But if I go beyond 50% throttle, I get 50%+ normal thrust. I know, my explanation doesn’t make much sense but neither does the actual thrust reverse that I’m getting lol.

Also, the reverse thrust button doesn’t really serve a purpose anymore. Since part of the physical throttle always reverses thrust by default now.

I’ll see if I can make a video of it.

This is exactly how it works for me, currently, on both PC and Xbox using two different peripheral setups.

Something whacky is going on.

Glad I’m not the only one! It’s such a weird issue. Especially since it used to work fine before.

You misunderstood or I quoted you poorly.

It is working correctly for me.

I have Toggle Reverse Thrust mapped to a button. I press it and 0-100% throttle are now 0-100% reverse throttle.

1 Like

Are you, by chance, using a Thrustmaster TCA Sidestick? If so, there are two modes available for use of the throttle. Mode 1 is normal 0 - 100 throttle. Mode 2 reserves the bottom range for thrust reverser and then engages 0 - 100 throttle about 10% up, just like you explain.

No but I am using the Thrustmaster Hotas X. Maybe similar issue with that?

I’m using the Hotas X. No issue for me.

You have Toggle Reverse Thrust set rather than Hold?

You’ve ditched the “Throttle Axis” and switched to the Throttle Axis 1 and/or 2 and/or 3 and/or 4?

Because when they altered Throttle Axis, I saw some really weird throttle behavior. Unmapping it and switching to the numbered axises fixed it.

Yup, that fixed it. That’s really weird but whatever, thanks mate! So happy that it finally works again!


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.