Ongoing stuttering problem

I’ve submitted a bug report to MSFS Zen desk twice now and in both cases the case is marked “Solved”. Unfortunately I have never received any help on this so I’m reaching out here.

Please see the following video:
Stuttering problem

I am afraid that you will never see better performance with your hardware. That i7 chip is 7th generation and is limiting your game. It is a mobile class processor, so I guess you are using a laptop. Mobile processors are always going to underperform, so that they can be operated at a reasonable temperature. Laptops just do not have the physical space for more aggressive cooling. On top of the fact that the GPU of a laptop is basic at best. I don’t recall you mentioning what GPU you are using. My suggestion is to buy or build a current generation desktop PC with a discreet graphics card.

Good luck sir.


Well, I’d have to disagree that it is my hardware since the sim worked great prior to the Japan world update. Unless there was some incredible change in the code at that time, I would say since I had very nice performance (as you can see between stutters in the video), that it must be something else. Thanks for the reply though. BTW, I have an nvidia Quadro P5000 as GPU.

You could try to reinstall. It sometimes works.

There are also a number of videos on configuring Windows settings, NVidia Settings before even looking at settings in MSFS. Certainly worth a look. It helped me with my mid-ranged system.

Do not reinstall. It’s probably just not optimized from latest patch. See how next week’s patch goes.

Also, update all of your graphics drivers if you haven’t already

Did you watch the video? That’s far from just “not optimized.”

1 Like

I didn’t watch it. Sorry. Not sure what else to tell you.

Your CPU frequency is the main problem there if you can’t get consistent ghz it will stutter. The sim needs constant speeds over 4ghz to run even that is not a full guarantee for smooth performance.
What do you have your laptop power mode set to?

My power settings in Windows 10 are to never sleep when plugged in.

I guess what is still confusing me is that MSFS used to run fine before the Japan World update. Now I know I’ve updated my nVidia drivers a couple of times since then (with no change) and I think there was at least one Windows update, but again no difference. What’s weird is that is seems so regularly timed (almost like a cache being reloaded). The stutters happen even when the sim is paused and affect the whole PC system. Once I go back to the home screen or quit MSFS entirely everything works normally.

If I was having some sort of underpower CPU issue, why would the CPU be straining when nothing is happening (paused), or I’m sitting on a dessert tarmac just idling?

BTW, does anyone know why the Zen Desk keeps marking my bug reports as solved? Its kind of a “We don’t give a …” impression on my part .


I had in the past also some stutters, that was relating on old installations, trash files, trash reg strings and so on.

I think if you follow this video, you should get rid of the stutters:
if you search for this video on youtube: Top PC Gaming Optimization & Maintenance Tips (2020)

If not, you need to check temperatures, if some component (north bridge or south bridge), ram, nvme drives or ssd drives are getting too hot, you will experience stutters!

How I’ve fixed it?

My mainboard has the nvme just under the rtx 3090, So I changed rtx 3090 slot (to the third slot that has x16) after that i put a ventilator that is cooling nvme+ram+north bridge and now all games running without any stutter.

Hope this may help someone else too…

Kind regards.