OpenTrack & AITrack (help) (resolved)

Hello,

I have big difficulties to make an head tracker working.
I don’t know where i’m wrong :frowning:

  • I’m using Droidcam with my cellphone. It works.
  • I have the last versions of Opentrack & AITrack.
  • “UDP over network” is selected (port 5555) as Input and freetrack2.0 as output.
  • AITrack have port 5555.
  • I click start on both. I can see my face full of pink dots inside a blue square. Nice !
  • But no data on “Raw tracker data” or “Game data”, filled with empty “[]”.
  • In FS2020 I have a new input called TrackIR with no bindings.
  • When i’m in flight and move my head, nothing happens.

Did I missed something ?
Thank you if you can help !

EDIT : I found some help on Discord, changed 5555 with 4242 and it’s better !!!

EDIT 2 : It works !!! This is a strange experience and I think I have some adjustments to do, but it perfectly works.

=> I don’t know if this post can help someone or if I have to delete it.

1 Like

helped me immensely. thank you. i’ve been fighting with this thing. still not perfect as i have a huge lag with my droidcam connection via usb.

I found the following video helpful: https://youtu.be/LPlahUVPx4o

I did not have to pick “Use Remote OpenTrack Client.” I downloaded the latest version of both OpenTrack and AITrack yesterday. Both OpenTrack and AITrack “out-of-the-box” were set to use port 4242. I changed the control axes as shown in the video. I did NOT have to do ANYTHING in MSFS. It worked straight away. If AITrack and OpenTrack are properly set up, independent of running MSFS, when you move your head along the camera axes you’ve enabled, as seen in the AITrack camera view, you should see the octopus in the OpenTrack dialog move back and forth. When that works, you can launch the sim and it should just work from within the sim. (you have to press the Start button on both AITrack and OpenTrack, obviously). And you probably want to adjust the mapping curve options in OpenTrack to reduce sensitivity around 10 deg head movement or less, perhaps make the curve more exponential going to the right - but I found it’s easiest to adjust the curve working right to left and I put the maximal response at about 70 deg head rotation as unless you have a very big, curvaceous monitor, you can’t see much on the screen even looking sideways as you approach 90 deg head rotation to left or right.

As soon as I spawned in the air, before I clicked “FLY,” I found the head tracking was working as I could look right or left, up or down, and the camera view in the cockpit changed. I had killed whatever setting was necessary to enable a zoom in or zoom out as I couldn’t do that with the active axis settings suggested in the YouTube video. Camera rotation by head movement worked for the cockpit view, the external camera view, and the drone camera view. I don’t know why but at times with me holding my head absolutely still, the camera view would go all bouncy while flying. I read somewhere that using the AITrack/OpenTrack combination does cost you some FPS - so perhaps the camera bounciness was in moments when I had a CPU/GPU overload? TrackIR from Natural Point (coming Wed!) is supposed to use a separate thread from any MSFS is using so I’ll see how that works comparatively soon.

Besides bounciness at times, there were times when there’d be a bit of a lag while moving my head and then the camera would suddenly jump to catch up. So anyone who doesn’t like microstutters might not like the AITrack/OpenTrack combination.

But in freeing up your hands to move your camera view with your head, it really kicks MSFS up a notch. When flying in mountainous terrain, it is now so natural to look to the left or right to anticipate where one is going (without having to worry about losing control or crashing into something while one is fiddling for camera views). Thanks to Microsoft and Asobo for making use of head tracking in MSFS so relatively effortless! I hope that they keep working to improve it as it makes flying in the SIM even more of a VR experience. The change in view as you move your head makes the imaginary world more real life, more 3D-ish.

OpenTrack not working for me. It works perfectly in AeroFly FS2 - I just start it and head tracking works with nothing extra to do in AeroFly. With MS Flight Simulator 2020 I do exactly the same as I do in AeroFly and nothing happens. No Head tracking at all.

As soon as I posted this, I went back and solved it! I think I will leave this post in in case it helps someone else. I had set up game detection in Opentrack and forgotten that I had. What was happening was that I was starting OpenTrack before starting the sim, selecting START TRACKING and then game detection was staring it again so there was confusion to MSFS 2020. Obviously AeroFly FS2 didn’t care about this (as I had setup game detection for that as well) but MSFS 2020 did care. So now I start Opentrack but don’t START TRACKING I leave it up to Game Detection to start the actual tracking and it works perfectly

1 Like

I couldn’t do anything anymore after the latest update, but it may have been something I inadvertently did. Anyway, I seem to have been able to address my issue. There is a possibility to choose your profile in opentrack. There was a default.ini and a MSFS 2020.ini profile and both didn’t work.

But I had also made a profile for use in Condor, aptly named condor.ini. That worked, I am at least able to use the tracker again. Hopefully this helps other users of this software too, have a nice day.

Cheers, Marc