OpenXR:200% MSFS render scale:50% = incredible clarity and smoothness on G2

Hello, I was trying to fine tune my newly acquired 3080 TI and wanted to share this setting which gave me great smoothness (no more stutters) and clarity in VR

OpenXR (latest update):200% MSFS render scale:50%
OpenXR use latest preview +Motion reprojection to automatic
Reverb G2
i9-9900k
RTX 3080 TI
Windows 10 latest update
HAGS on
Game mode on

2 Likes

Have you tried OpenXR 50 and render scale 200? I feel like this is just having 100 dollars, and splitting it into varying amounts in different pockets. It still always totals 100 dollars.

Basically, you’ve just done the following 100 / 2 = 50 50 x 2 = 100.

Doesn’t 200 in OpenXR and 50 in MSFS change the render load to OpenXR compared to making MSFS do the heavy lifting?

I think all you are doing is lowering the resolution in OpenXR from 4320 x 2160 to 2160 x 1080 then raising it back up in MSFS to 4320 x 2160.

I assume OpenXR is rendering regardless.

I would assume that OpenXR would be the same as the post processing rendering in “Secondary Rendering” in 2d.

Therefore MSFS at 50% would reduce the primary load being done by MSFS and OpenXR would be doing the post at 200%.

Your example would double the load in primary rendering being done by MSFS and reducing the post render being done by OpenXR.

I can easily see how reducing the MSFS thread load would result in a smoother display package being sent to OpenXR for post.

I’ll give it a try. Supposed-to’s often are invalid with this Asobo spaghetti code. The old 200TAA in 2D definitely did work pre-xbox and that made even less sense.

With this game, sometimes up is down and down is up.

To the OP, don’t let the naysayers get you down. I’ve posted plenty of observations that help, only to be told by the cheerleaders that my eyes are lie’n.

I’m not really sure. I’ve read some threads on here about it but it all seems like trial and error. I’ve followed a few Youtuber settings, my favourite currently being PieInTheSkytours. I have OpenXR at 100, MSFS 85 TAA and reprojection disabled. I switched to OpenXR 85 MSFS 100 and it seems exactly the same to me,

Not trying to be a naysayer. It’s just that there a million and one suggestions, tricks and fixes that some people claim work, and others don’t. I think, for the most part, rather than being objective, tangible improvements that will work for everyone, they reflect that vast amount of individual variance between our respective PC hardware and configurations.

Ultimately, I feel all the performance changes, for better or worse, have come from Asobo’s updates.

3 Likes

I think these kind of observations, like the suggestion from @PendantIsland68 are extremely valuable.
Anything that is measured by our senses is highly objective. If I touch something and it feels warm to me, you may touch it and complete disagree.

  • “Can you smell that?” - “What smell?”

  • “What is that whistling noise?” - “What Noise?”

  • “My VR looks amazing when I set it up like this.” - “I tried that and it looked blurry to me”

If someone recommends you try a new restaurant because they had a great meal, I suggest you try it and decide for yourself if you want to go back.

1 Like

Yes, I agree. It totally depends upon a person’s prior experiences and expectations. Somebody (like myself who only rarely watches films and TV shows) can give their opinion on the best film ever, and someone who has watched many films in that genre might find it totally derivative and devoid of any originiality.

When you also factor in what hardware people have and what standards they have its virtually impossible to sift through all the suggestions for MSFS.
Some people will swear this sim runs perfectly fine on a 1080 Ti with a G2 whilst others will criticise their performance as unsatisfactory with a 3090.

I do think the sim performace has improved substantially in recent weeks. Prior to SU5 flying in areas of heavy photogrammetry, like Toronto was painful. Now, there is no discernable difference in the smoothness for me wherever I fly. But it was entirely Asobo that did that with their updates, and all the dozens of hours I’ve wasted tinkering with settings, rolling back drivers, experimenting with HAGS on/off, full screen optimisation enabled/disabled, texture set to quality/performance, etc just felt like adjusting sliders where the overall output was the same regardless.

I’ve got to the point now where I don’t care about anything other than substantive Asobo changes, nothing else really seems to matter.

It’s kind of like calories in calories versus the million and one dietary hacks and programs. Ultimately, its just energy balance.

Yes I have tried OpenXR 50 and render scale 200 and the result is same clarity but a stuttery mess… So there is really something about smoothness in having a high value in openXR. It is also smoother and sharper than OpenXR=100% and render scale=100%. HAGS needs to be on, it is not as smooth otherwise

The difference is very noticeable in VR with my hardware, however not sure it would work with AMD CPU/GPU

2 Likes

HAGS on is unusual, in that every other recommendation I’ve seen says turn HAGS and Game Mode off and disable fullscreen optimisations. I’ve not seen anyone recommend turning those on, although to be fair, I’ve never tried, I just went with the herd and turned them all off.

I’m currently using OpenXR at 100, in game at 85 with motion reprojection disabled as that ruins the image quality for me. It’s very smooth currently, really improved in the last few weeks, and looks great, although I wish I could ruin it at ultra everything as I can with 4K flatscreen.

I have terrain and object LOD at 125 and get irritating pop in on ships, and airport objects, Apart from that I’m really happy.

I might try your settings tomorrow to see how they work on mine as our specs are very similar 10850K 3090.

Your settings do work very well, especially when preventing windows desktop manager and the mixed reality processes from running on core 0 and 1 (since you’re putting more of the workload onto them and less on the sim), but in my own experience there is one unfortunate downside with running less than 100% render scale in the sim with WMR and motion preprojection enabled: If you are using TAA the clouds stutter noticeably as you fly past them.

There’s some kind of bug there with the rendering, as they render smoothly with FXAA or DLAA, and they render fine with TAA if the sim’s render scaling is set to 100% or higher. FXAA and DLAA are kind of nonstarters for VR though given how much shimmering there is with trees.

Unfortunately once you see that cloud stutter you can never unsee it. The faster you fly the more noticeable it is, and it drives me a little nuts. I’m kind of hypersensitive to any stutters though and dancing with clouds is my favourite kind of flying, so it might not bother other people.

Thanks for your suggestions though!

Do you fly in cockpit view or in third person view?

There where observations a while ago that notice that raising oxr have more impact to the environment and raising render resolution do the same to the cockpit details.

Btw, I fly 100/100 again with 3090 and I am fine.

How do you do that?

There are a couple of easy ways to do that. For quick testing you can just open task manager, go to the detail tab, and right click a process (dwm.exe for example) and select “set affinity”. You can then uncheck cores 0 and 1 to prevent that process from competing with MSFS for cpu time on those logical cores. Dwm.exe and the WMR processes are multithreaded and will use multiple cores, so I just prevent them from using the first physical core, so that MSFS can have that one mostly to itself.

If you want a more permanent solution, along with a number of other nice performance tweaks, you can use the free version of Process Lasso to do the same job. I allow MSFS to use all cores except 0 (assuming hyperthreading is enabled) and force the following processes to not use cores 0 and 1… (assuming WMR/Reverb G2)…

dwm.exe
MixedRealityPortal.Brokered.exe
MixedRealityPortal.exe

For Oculus I would do the same thing with their processes. Motion reprojection and ASW are very cpu intensive.

I have found that keeping those processes from competing with MSFS for core 0/1 time really helps smooth things out in the sim. Also if you do end up using Process Lasso I would recommend disabling “Windows dynamic thread priority boosts” on flightsimulator.exe. On my machine (i7 6700k and 3090) disabling that has helped relieve some persistent stuttering. Additionally, starting Process Lasso after the sim has fully loaded works best. FS doesn’t like being core restricted on startup, usually crashes if it’s not allowed to access core 0, but it has no issues with having its processor affinity being changed once it’s running.

Btw, this is assuming a Windows 10 install. With Windows 11 I have no idea if these tweaks are still applicable, given the new thread scheduler coming for it for Alder Lake etc.

Good luck!

I fly in cockpit view. It is very sharp on the terrain, less on the cockpit but good enough for me

Thanks, I’ll try that. Not sure I follow the logic in your sentence above. It reads like you disallow MSFS on core 0? But you are talking about it running on 0 and 1?

Yes, I know that arrangement looks a little strange at first.

The reasoning behind not allowing FS to use logical core 0 is so that it can’t overload that first physical core by using both of its logical cores fully (which it will if you let it). A ton of windows processes must also share that first physical core, along with most of the drivers (many of which are not multithreaded), so it is easily saturated if you let FS max out both threads.

Restricting it to only use the second logical core gives that physical core some breathing room to handle everything else without getting in the sim’s way. For me it really helps reduce stutters and pauses. Of course let FS use all the other cores fully.

FS does most of its heavily lifting on the first physical core, the things that are not easy to multithread, like rendering, physics, audio etc, so it hits that one with a constant high load. The other cores are used primarily for background scenery and texture loading etc, so their usage is lower and more intermittent. That’s why I dump the WMR processes and DWM on those cores, plenty of breathing room left on those for that work.

I tried your settings on my Ryzen 5900X and the first results are very encouraging! I had the smoothest few flights ever. Microstutter is almost (if not entirely) gone. Some stutters are unavoidable, probably when preloading scenery or somtghing like that. But overall - amazing resuls, the best so far.

As I have 12 physical cores - 24 logical ones, I used Process Lasso, disallowing core 0 and cores 18-23 to MSFS (loaded in a .BAT files after the sim is running), limiting all other sim software to logical cores 18-23 (VoiceAttack, MobiFlight, FlyPT Mover, SimShaker) and disallowing all WMR software and DWM from using 0 and 1.