OpenXR NIS upscaling software - Release thread

Have done so. And, yes this seems to be working better than Beta1. I’ve only tried it so far on a 50/50 setting with OXR 200. Pretty solid 30FPS (locked) and smooth, relatively crisp. (G2 /1080ti).
If I have some time later, I’ll try some other iterations.

Thank you very much Matthieu for your great contribution to the abandoned group of VR users in MSFS2020. I am a user of Quest 2 with link, and I have a question that I wanted to consult you. I do not know if you know that the oculus debug tool has an option to activate the sharpening, is it necessary to activate it or not when using your magic software?
Thank you very much again

Thank you Matt. Great work :+1: :grinning:

1 Like

This is exactly, what my father described. :smiley:


I have tried it and have good visuals.
Few frames more I think but the resolution is lower so that makes sense I think.
Trying to figure out what sharpness level to use. I have the feeling I dont really see difference between 0,1-,02,0,3 or am I wrong.
What so be the sharpest setting?
Using Open XR100 ingame rendering 100.
Scaling 0.85 and sharpness 0,1 now.
11700k 3080 gives an overall good result!

Waited for the beta eagerly as I have no experience to mess around with Windows (only reason to have one is FS2020), installed, said yes to many boxes, opened the app and started FS2020 - which refuses to run anymore. “File system error” or something like that. Tried to uninstall the beta but it did not make any difference. Cannot open FS anymore. Anyone would like to tell a long time Mac user how to get back to the air again? Lenovo Legion 7 laptop, RTX3080 and 32Gb

I cannot get the github .msi file to download using Windows 11. Seems like security has a problem, just says .msi files are not usually downloaded. Help, please. I don’t have any other NIS add-on files loaded.

This has most likely nothing to do with the beta. To make sure, please post a screenshot of the exact error message, maybe we can help from there on.

Hi there, I am using 497.29 as it is giving me best results for VR (G2), does this driver also supports the function to disable NIS in NVIDIA?

Had to google how to take screenshots on Win :wink:

Anyway I believe this indeed is related to the installment of the beta, been flying with zero problems since summer. Also today before installing.

OK, googled with the error code and found a tip saying that I should sign out / in to MS Store. Seems to have solved the issue as FS starts now normally, phew… However I got so scared of potential reinstall that I’ll wait for the next beta release before trying again.

1 Like

Wow this works great, what a difference! RS in-game 100, OXR 100, NIS 80 RS, and 50 S. Idk if I could go higher in the NIS settings but the way it’s running at the moment is great! Great work thanks again!!!


Not the author, or associated with the author, but I am certain your experience was %100 coincidental.

The tool does not touch your sim installation at all, nor does it touch your microsoft/xbox store login.

It simply installs itself in your program files directory and adds a registry entry that OpenXR dev tools will catch which loads in the API so it will redirect the output to the NIS scaler.


Sorry you had issues, however, your error seems to happen before OpenXR is loaded (before you even reach the point to enter VR) so it does look unrelated. I can’t explain what happened on your setup, but it just looks like an unfortunate coincidence.

If this is the Bit Defender message, you have to do “Run anyway” to bypass it.

My bad, was just a weird coincidence. Had to try to install the beta again and it indeed makes a difference, beautiful work!

1 Like

Thanks for the first Beta (and Hotfix), I’m running the following on my PC:
OpenXR = No Custom Resolution/Unticked, which I think it’s 50% (if I have this on Custom 100% it’s clearly a higher Res)
In game Render Scaling = 100%
NIS = 70%
Sharpness = 5%

As per the other thread I have been able to bump up the general graphics settings, mainly Clouds and Textures to Max (originally medium without this tool) and a few other areas with FPS still to spare from what I was getting without.

Toolbar text is a bit fuzzy though, my theory is I need to run OpenXR at 100% (as suggested) but then I’ll lose all FPS improvement and I’ll have to have NIS really low to gain it back…I’ll look into this later.

2070Super, i9-9900k, 32gb RAM, HP Reverb G2

1 Like

What a superlative add-on! I am relatively new to VR, with a G2 on an i5-11400 system with 3060ti. I ran the Alpha 4 yesterday, with OXR 160, NIS 100, in-game 70, and sharpening 10 (another user’s recommendation) and it was epically more crisp and clear visually for me. Made a huge difference to my enjoyment of VR. Can’t wait to try the Beta with in-game 100!

Add me to the list of people who want to beer you (or crowdfund a headset)


I’m really interested try NIS but I’m a little confused by now if I can use it. At the moment I only fly on VR and doubt back to 2D someday, so the main issue is reach a better performance. I use Oculus Quest 2 with OTT and ODT mainly to adjust the super sampling on 1.1 and teh FOV on 0.8, this is my best settings after months triying to get the sim flyable, my rig is a RTX3070, 32 GB RAM, i5 intel 9400F. With this software and hardware, can I use OpenXR_NIS_scaler?. If it’s right, is just to install de .msi file?.

For me the api is listed in oxr but no listing in local cache ?
I also have the desktop icon which I can select, does this need to be open or does it use the rs & sharpness from it automatically ?
I only ask on this part as once I go back into it after a fresh load of the computer the flight sim isn’t saved inside this i have to select it again.
Hope all this makes sense its confused me that it isnt listed in local cache, yet works as per the ctrl & f1 test ingame.

Sorry, it isn’t that it won’t run …it won’t download from Github.