OpenXR runtime missing in SteamVR for Pimax-4K

A key component of SteamVR is missing: OpenXR runtime

SteamVR app/Settings/Advanced Settings-Show/Developer/Current OpenXR runtime:
only SteamVR option is available and the option OpenXR runtime is missing.

is that normal?

This is really badly explained.

What headset do you use?

If it uses Windows Mixed Reality, you have to set it up in the WMR software.
If it uses Oculus, you have to set it up in the Oculus software.
If it uses SteamVR, this is what you have on your screenshot.

Basically each software has an option to set its own runtime as the default one for OpenXR.
But you cannot change to WMR or Oculus from SteamVR for example.

  • If you open the Oculus software and set Oculus as OpenXR runtime, when you’ll open SteamVR settings, you’ll see that SteamVR is not the default OpenXR runtime anymore and you will be able to set it up back to SteamVR.

Hope that clears things up.

I use Pimax4k.
When it is activated with Pittool & SteamVR, MSFS freezes at 80% from Start.
Otherwise, MSFS works fine with TrackIR.
So you say it is ok that only SteamVR option is available?
I have sent the msinfo32 report to MSFS support over a week ago and it seems they still did not find out what causes the start-crash.

Pittol Version: V1.0.1.271
SteamVR Version: 1.21.4 (1639433079)
WIN 10-64 Pro. MoBo: ASUS ROG STRIX Z390-F GAMING. SSD: SAMSUNG 970 EVO+ M.2. CPU: Intel Core i9-9900K. GPU: MANLI RTX 2080 Ti. RAM: HyperX 3200 MHz 32 GB. Monitor: ASUS VG278H 3D /VR: Pimax 4K/TrackIR-5/SAITEK X55-Yoke-Rudder-Trim Wheel.

In my opinion yes, this is normal.
But I don’t know anything about Pimax ecosystem so maybe changing your first post’s title and including Pimax in it will bring people who owns one and they’ll be able to help.

Hi,

I have the same issue as you using the Pimax 8k. Did you find a solution yet.

It’s been almost three weeks now that I’ve sent MSFS Support the required msinfo32 file, and still no reply. Once it’s resolved, I’ll forward the result to this thread.

Thanks… from what I’m understanding Pimax doesn’t use openXR therefore steam runtime should be showing steamVR.

However my issue is if I start steamVR before MSFS the SIM will get stuck on 80%. But if I start the SIM first and start a flight then switch to VR I get the message VR failed, openXR is not installed.

i must install the steamvr beta, to activate openxr in steam for the first time,

but, it was 12 months before, dont know if was a other solution in the meantime.

This is exactly the same problem I’m facing!

So if Pimax by default does not use OpenXR, then SteamVR starts without the “Current OpenXR Runtime”. But it seems when MSFS starts, it looks for the OpenXR while booting and it gets stuck on 80% because OpenXR is missing.

That explains why a lot of Pimax users are facing the same problem now!
MSFS needs to re-add this SteamVR Patch to its VR-Parameters as a surrogate for OpenXR to solve this problem once for all. And I say re-add because Pimax-VR was functioning fine in MSFS at the beginning…

I have a weird feeling that since that MSFS-Update 12 months ago, they deliberately excluded the Pimax-Algorithm to cause this issue. Is this maybe the plausible explanation as to why MSFS Support is NOT responding to this issue?? We know how Chinese Brands are being fought in the Western Market because of their technical superiority and low prices and the kind of Media oppression it has been facing. (Soon Pimax is bringing their world-first 12K VR-HMD on the Market)

I don’t buy MSFS’s lame excuses that for 12 months now they couldn’t solve this problem, and honestly, I have no interest in flying in MSFS without VR. In fact, I haven’t been using it since this problem occurred.

You’re probably right, as I was having no problems prior to the SIM up date.

I have had some success today though. I found a thread today that helps.

Sorry can’t post the link: won’t let me.

All I need to do is start PITOOLs then start MSFS, load a flight then switch to VR in SIM. I get the VR Fail message and also the Steam VR fail message which blocks the pimax headset. I unblock the headset and close Steam VR. (Not using the restart option) I then simply restart Steam VR via Pitools then switch to VR again in SIM.

This works for me now.

Not sure if I needed to but I have also uninstalled mixed reality portal from windows. In the thread they say MR portal can confuse MSFS. Just google how to uninstall MR portal if it doesn’t show up under settings, it requires a slight reg edit to make it show up in order to uninstall it.

It’s a good work around for now… I hope you have success, let me know how you get on.

Looks like a good trick out of the magic box…

Every step worked fine up to switching to VR again in SIM, where MSFS froze.
Repeated this procedure a few times with the same result.
There must be a reason why it is working on your pc but not mine.