OpenXR Update from Nov 17th - Reverb G2 CTD after switching to VR and back

I am having the same problem and currently trying to find an old driver to revert back to but no luck yet.

Same problem here since the OpenXR update yesterday and presumably no way of reverting to the previous version.

same ■■■■ here !

I’ve noticed that if I try to switch out of VR whilst actively flying, I will sometimes CTD. But, if I active-pause (Escape) and then switch out of VR, it switches out just fine. I have not extensively tested this, but I can say that since the new OXR update came down the only CTD’s I have had were while switching out in flight. And, I can not recall a CTD while switching out when paused.



Will try today, thanks. But this would be more of a work-around.

There is a bug report on that issue, please don’t forget to vote if you’re affected:

1 Like

same here CTD when switching 2D / VR in C172 and others

Please vote in the Bugreport posted above if you haven’t done so yet. Thanks.

1 Like

Thank you, this works for me.

If you did not read it in the bug thread yet - there has been a hotfix OXR release (v109) which appears to solve the whole issue for most users.

1 Like

The latest update (23 Nov) fixes it for me. I have to use the - Use latest preview option.

Sorry for not having seen this post earlier. I’ve posted the procedure how to update to the latest OpenXR version here:


I’m with the OpenXR team at Microsoft.

There are a few outstanding issues that we have been made aware of. We want to thank the community for reporting these issues.

We are going to roll out an update to the OpenXR runtime later today which we believe will fix 2 issues that are causing crashes or failure to initialize the VR mode.

Please be sure to install the OpenXR Developer Tools for Windows Mixed Reality and enable “Use latest preview OpenXR runtime” in the “Developer Settings” tab. The versions that have the fixes are:

  • 108.2111.23004 (this one is rolled out gradually over a few days)
  • 109.2111.23003 (Preview - this one will go to everyone but needs to be explicitly enabled with the Developer Tools)

You may check what version you are using by inspecting the “System Status” tab (but please give it a few seconds to update after you switch to the preview runtime).

If you are not getting the new 109.2111.23003 version automatically, try to open the Microsoft Store and force the update from the “Download and updates” screen by clicking “Get updates”.

Again, this is not live yet, it should be available by the end of today (US time).

Thank you all for your patience.


Thank you very much! Good to know, that someome from the Team is reading about our issue.
For me, since the new openXR update from 2-3 days ago, everything works perfectly at the moment. Will look out for the update.


Will definitely be looking forward to the update.

Sorry if this is a numpty question. Do I need to run my headset with the WMR portal and the OpenXR dev tool open, or does OpenXR “kick in” when you start up VR in the game once you’ve downloaded and set up the dev tool?


Only WMR needs to be “open”, but the OpenXR Dev Tool must be installed to be able to use the latest preview!

Thanks @RPthreenine - I’ve managed to stumble my way through it. It seems to be offering me a very smooth experience.

Definitely worth doing.

Thanks again

1 Like

My Open XR for WMR in Developer Tools shows it was updated in the apps section but version number did not change - will see if it does once I start flying some today.

Thank you for the information. Can I ask you a question related to OpenXR? From what I can figure out UltraLeap / LeapMotion hand tracking hardware is working with SteamVR OpenXR runtime, but it isn’t available for WMR OpenXR runtime. Is there a reason for that? Are you planning any kind of support for LeapMotion hardware? Is there anything that prevents developers from writing a driver/middleware for VR controller emulation on WMR OpenXR? Thanks.

1 Like