Getting out of VR with Ctrl-Tab causes CTD (Reverb G2)

PC
Steam
No Dev. Mode
Empty community folder
1.21.13.0
HP Reverb G2
Windows 10
WMR Runtime 108.2111.10005
WMR API version 1.0.18
Use lates preview OpenXR runtime On (in OpenXR Developer Tools for WMR)

Getting out of VR with Ctrl-Tab causes CTD. As the toolbar can’t be operated in VR (known bug) this is extremely annoying, as it is impossible to temporarily quit VR, activate an option in the toolbar (e.g. a pushback) and go back to VR.

This is a known issue, however still not fixed. I reverted back to runtime 1.07 by deactivating “…latest preview runtime” and don’t experience these CTDs anymore.

1 Like

I unchecked the “Use latest preview OpenXR runtime” in the OXR Dev. Tools, restarted the Mixed Reality Portal, but the OXR Dev. Tools is still showing WMR Runtime 108.2111.10005 and I’m still experiencing CTDs when getting out of VR.
How did you manage to go back to 1.07?

image
image

Well, actually it may be more complicated than that - apparently what created a regular crash (not a CTD) before is now bringing back the old WU6 RE-initialization bug for some (that was meant to be fixed in SU6 but apparently just turned into a crash), and apparently this is now a crash for some others.

This may be in context with yesterday’s OXR update that was forced to to install when you updated FS via the Store today.

The regular VR-related crash on exit is still the same though.

Weird, I did just as you did, but a couple of days earlier and did not touch this setting since then (and won’t now).

Please navigate to the system32 folder shown in your second screenshot and tell us what date & time the two files MixedRealityRuntime.dll and MixedRealityRuntime.json are. Mine are 2021/02/18-21:22:23 and 2019/12/07-10:10:11, respectively. By the way, my API version is the same as yours.

I have no idea if that would work out or if there are more files that need to be swapped, but if versions differ, I could provide you with my files.

Please elaborate, because I bought MSFS via Steam. What exactly was updated yesterday - runtime or API?

Yup +1. For me it started even one day before updating Open XR. Maybe, the problem is a windows update? Would´t be the first time.

I can switch back and forth when in the main menu(!). Can someone confirm that? But as soon as I loaded a flight, I sometimes manage to switch once, but once more leads to a CTD.

Another idea: have you tried reverting that specific update under Windows Settings - Updates - …?

Having intermittent CTDs when switching from VR-2D is an issue I’ve had for pretty much as long as I can recall. In my case, it’s always caused by PerceptionDevice.dll_unloaded when checking the Windows Event Viewer Application log after a crash.

I’ve created a support ticket in the past with Asobo where they started with the usual stuff such as, try to reinstall MSFS, reinstall Windows etc…sigh.

At this time and based on how this issue never seems to be sorted, I hate to say I’ve almost given up hope it will ever be fixed. I have learned to live with it and try to avoid switching back to 2D as much as I can. Since I never know when that will result in myself being back on the Windows Desktop…really quite sad.

This is what I see in the log:

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: PerceptionDevice.dll_unloaded, version: 10.0.19041.746, time stamp: 0x24cb77e5
Exception code: 0xc0000005
Fault offset: 0x0000000000012f0f
Faulting process id: 0x1898
Faulting application start time: 0x01d7dd585897db7a
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: PerceptionDevice.dll
Report Id: 337e5659-fae0-41b5-b242-f1b2e5d9e84e
Faulting package full name: Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

System: i9 9900k, RTX3090 (MSI SuprimX), 32GB 3200 RAM, SSDm2, 850w BeQuiet PSU (definitely no thermal issues, no probolems with other Games).

What I´ve tried so far:

  • deinstall all unnecessary software including Afterburner/Riva Tuner
  • change Monitor refreshrate 144/120/60
  • Switch to HDMI Cable instead of Display cable for my 2 Monitors
  • Disabled/enabled Vsync and Gsync
  • Used a very old nVidia driver from June 21
  • removed overclocking from my CPU
  • turned HAGS in Windows On/Off
  • changed XMP Profile for my Ram sticks from XMPI to XMPII
  • Added 32GB RAM (so 64 in total, had that around but didnt use it)
  • disabled community folder
  • deinstalled all WMR Portal and related software like OpenXR Dev tool
  • Updated all Motherboard features: BIOS, Chipset… anything
  • Turned off MS antivirus/Firewall features
  • switched BIOS from Gaming to Silent mode on my MSI RTX3090
  • Disabled “preallocating Virtual Monitors” in regsitry (What this does? google it please).
  • removed every USB device except for the Reverb G2.
  • Used cable Internet instead of Wifi
  • Installed the MSI monitor drivers (I have two monitors from MSI)
  • Used just one monitor

New:

  • Used nVidia Hotfix Driver 496.84

I can switch back and forth VR <–> 2D in the MSFS Menu but when loaded a flight I sometimes manage to switch once but in 9 of 10 cases there is a CTD (Screen freezes, strange freezed noise followed by MSFS closing to desktop). In some rare cases, I can switch back from VR but reenabling VR shows the message “No OpenXR …found, please make sure you have OpenXr installed”.

Everything worked fine until one Day before the new OpenXR release.

In Windows eventviewer, there´s always a message “nvlddmkm” doesn´t work anymore and was recovered (translated roughly from german).

nvlddmkm is nVidia related to the nVidia driver but I don´t know if this is the root cause or the driver crashed because MSFS/VR did?

My thoughts: If you goole for nvlddmkm and eventviewer, you will see a lot of answers and many solutions that didn´t help. I tried many of these. If you guys have another idea, please let me know.

Does anyone have the problem with an AMD Graphics card? All people here have an nVidia card?

I think it is related to something about the nVidia Driver. I don´t know.
I spoke to one guy in discord who has almost same setup and has no problems switching. So many people of course don´t have this problem. I really hope, the community finds the answer of what causing this.

RTX3090 here with latest driver. I’ve reverted back to 1.07 by unchecking the “latest preview runtime” option.

Yes, this uncheck “latest preview” worked until few days ago.
I even don´t have devtools installed at the moment.

You don´t have any Problems, switching back and forth?

Ok I’m gonna be a bit more precise about the versions. I have no issues switching back and forth between VR and 2D using runtime version 107.2109.10010, which is the non-latest-preview version for me. However, I’m running OXR devtool (GUI frontend) version 1.0.18.

When I tried the latest preview runtime last time, which was about a week ago, the runtime version shown in devtools was 108.xyzsomething (don’t recall the whole version string) and VR-vs-2D switching resulted in insta-freeze/CTD upon attempting to switch back to 2D for the first time.

What versions did devtool show you when you selected latest preview vs. default runtime? And what the time & date of your /Windows/System32/MixedRealityRuntime.dll ?

I’m suspecting that the current default version might have been updated to 108.xxxxx and the latest-preview version now is 108.yyyyy. In fear of that I won’t use that preview runtime switch until this issue is fixed… :wink:

By the way - did you try finding and reverting the update that may have installed the flawed OXR runtime version under Windows Updates - …?

No. I don’t think you can revert to an older OXR version. OXR is not Windows Update related. Just through the MS Store.

At this moment, I completely knocked down my PC and am installing a fresh windows copy and a fresh MSFS Version as well… let’s see what happens.

Good luck and please report back about your findings!

1 Like

Mach ich, Klaus.
Will report back, Klaus.

Same issue here and was working fine up to an OpenXR update (which coincided with msfs update)