Getting out of VR with Ctrl-Tab causes CTD (Reverb G2)

Okay, now I have a completely fresh installed Windows and fresh installed MSFS → Problem remains! As soon as I siwtch back from VR CTD.

1 Like

Okay Guys! SUCCESS!

You have to enable “Use latest preview”. Now I can switch back and forth as often as I want.
Download OpenXR developer tool in MS Store.

I Know that most of us had to disable this option with the OpenXR Version before but know, try to enable it.

I´m not sure if I even tried this before I knocked down my whole system today!?

1 Like

I tried switching latest preview back on to no success still CTD when going back

Okay, there´s one little thing I did before but this would make no sense to me…

I reverted back to a very old Driver from June 471.11. Here I noticed, that I can switch back and forth again with “use latest preview” enabled. I then reinstalled the newest driver 496.76 (just on top of the old driver). and it kept working.

It sounds weird but maybe try it. Download 471.11 and try this with latest preview.

1 Like

There is a way to revert back to 107 via Windows restore point. I’ve just done that and am back on 107. It works as hoped, no CTDs anymore.

However, this is not a permanent solution. Anyone know how to report a bug to the OpenXR guys?

1 Like

I guess that will only work if you have a restore point saved at that time. Tried to look for OpenXR forums but not much joy on there. I think this will be one of those its not our issue from both OpenXR and Asobo

This is weird. I did the same steps as you, reverted to the old 471.11 NVIDIA driver and then switched to preview mode in OpenXR developer tools and have successfully switched back and forth between VR and 2D screens at least a dozen time with no freeze of CTD.

Interestingly, I did try switching before selecting the latest preview in OpenXRdeveloper, and I had the ‘Initialization of VR Failed’ message, once I selected to use the latest preview and restarted FS2020 all was ok. I wonder if this is a once off or if it will continue to play nicely for me.

Keeping my fingers crossed!!

1 Like

Thanks for your updates. After boldly posting that I was still on 107 I had my “Oh nooooo!” moment last night - by some nasty magic, OXR had been silently updated and it turns out as I suspected: the default runtime is 108.2111.10005 now and the latest preview is 108.2109.21002. Which is interesting because the 2nd part of the version number is higher for the earlier version. However, with both of them, I’m getting the CTDs. Awesome, thanks MS.

I had already tried reverting the latest Windows updates (Win10 here) but to no avail. I’ll see if I have any restore points and try the older NV driver version.

You don’t need a windows recovery point. You can download almost every older driver from Nvidia directly. I post a link. Give me some minutes.

Yes! Same for me. Before this, I always got the initialization fail. Really weird but happy, that it worked for us!

Thanks but I did not mean the NV driver - I have a collection of NV drivers of the last 6 months or so, so that’s fine. I meant reverting back to an earlier Windows recovery point to get back to OXR 107.

1 Like

I suggest deinstalling the dev tool and reinstal it.
For me, latest preview is: 109.2111.18007 and this works.
without latest preview, it says 109.2111.10005.


It now springs to my mind that the “V” in “VR” stands for “Voodoo” … :cry:

1 Like

Thanks, they just released a 109 beta today :slight_smile:

This solved the Problem for me!

Just re-install all WMR Apps (Mixed Reality Portal, OpenXR, OpenXR Dev Tools) and activate the latest beta (109.2111.18007) and it should work.


Can confirm that reinstall as stated above fixes for me too. How do you mark the post as the resolution?

1 Like

Confirmed here as well for Win10 with NVidia latest Hotfix Driver 496.84: reinstall of OXR including devtools gives me 108.2111.10005 as default and 109.2111.18007 as latest preview versions. Didn’t test 108, but 109 fixed the CTDs when switching VR vs. 2D for me.

Thanks for the quick fix!

1 Like

In my case it is even worst.
I have unistalled everything. Installed it again, Reboot, Latest versions as per screenshots below… and I cannot even get into VR with CTRL+TAB nor the assigned joystick key.

Did you check if your headset is working properly with other apps / games?

Can you post a screenshot of your WMR?

Yes of course it is.