Options Menu - Load/Save - .pln

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes and done.
Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
Opening ‘Load/Save’ menu only gives the ‘.FLT’ option - no ‘.PLN’ option.
In order to have .pln files visible, enter ’ .pln ’ (that’s “asterisk”.pln) into the “File name” box and press enter. .pln files will be visible.
Provide Screenshot(s)/video(s) of the issue encountered:



Detail steps to reproduce the issue encountered:
With sim running, Options menu - click ‘Load/Save’. Click ‘Load’ in next window. That opens the selection window - no .pln files and no "Plan files (
.PLN)" option in the drop-down box. In “File name” box, type " *.pln " and the .pln files are visible.
PC specs for those who want to assist (if not entered in your profile)
n/a
Build Version # when you first started experiencing this issue:
possibly always
Are you on the Steam or Microsoft Store version?
Store
Did you submit this to Zendesk? If so, what is your ticket #?
no

Have the same issue.

When pressing escape from the game, you get the “Options Screen”

Opening the Load/Save option

We are unable to load flight plans as stated above (.pln) due to the option for (.pln) is not available in the dropdown box as indicated below

FWIW, flight files (.flt) contain a pointer to the flight plan (.pln) but this pointer is wrong most of the time. There is a workaround. When Load/Save is selected, a Windows file selection box is displayed. It is “locked” to enter only a .flt file. To get around this restriction, put . in the filename box. This will now display both .flt and .pln files for selection. Or the flight plan name can be entered including the .pln at the end.

The entered flight plan should be close to the current flight plan. If a random flight plan is entered for airports on the other side of the country, navigation pointers get messed up.

I only use this technique whenever ATC goes goofy. I will cancel IFR and shortly after, ATC asks if I want to file an IFR flight plan even though I am currently flying VFR. I enter the name of my original IFR flight plan. This seems to reset ATC.

Regarding the .flt files, it appears that Asobo has designed these to be used or reused once and they are to be used before starting any other flight. I don’t think we are supposed to build our own library of various flights. Many of my older .flt files do not work after updates.

Load / Save Flight Files

Prior to starting a flight it is possible to both load a .pln and .flt from the Windows Explorer dialog that opens when you press the load / save button or space key.

Once loaded into the flight, after pressing ESC you have the option to load the same dialog but now it is no longer possible to load .pln, only .flt, the UI still says both .flt and .pln and I think it should possible to load .pln files after loading, which was also possible in other versions of Microsoft Flight Simulator.

This seems like an obvious issue but I could not find any thread, is there one?
I think this is an essential part that should work, as .pln as part of flight planning.
I would very much like to see this fixed.

UI

Only .flt inside flight

I believe you can FORCE to load a .pln ( what is missing is the Template *.pln)

If you specify a file name *.pln, it will then display all the .pln files, and you can select the one you want.

But yes, it should be fixed to display the template options of *.flt and *.pln

1 Like

that is useful, just tried it! So since it works already, should be an easy fix then for the Asobo team to just enable .pln there. :thinking:

should be … but now ULTRA LOW priority, as there is such a simple work around.

A simple work around that I’ve not come across until now… maybe it could be added to the known issues please?

I think it’s little things like these; where priority could also be placed as well; it’s often the little things that make big differences to the user experience. This little thing is related to the bigger feature; flight planning, used by many simmers.

Regressions should never be low priority. But apparently the French do things differently :smiley:

The reality is, the whole Flight Planning system within MSFS needs an extreme re-design, that goes way past the loading & saving of flight plans.

The world map system is severely inadequate, as is any creation or changing of all but the most simple auto-generated flight plans.

User waypoints are a total mess, as is the inability to specify altitudes for specific legs of a route.

The good news (if you can call it that), is that this whole area is missing from the SDK, so hopefully it gets a re-design to bring it to a more usable “Flight Simulator” tool , rather than a Game Play feature, and gets fully documented in the SDK.

Unfortunately, quite a lot of work - which does not have the Glam & Glitter of new Scenery, or other surface Cosmetic improvements, that seem to be what he masses are happily feeding on, and pushing sales.

Yes there is lots of potential there to improve the flight planning feature, would like to see this too, please do create a separate feedback thread or add to the existing ones, there are many threads with feature improvements and comments about flight planning.

My aim with this thread was only about the restoring/adding the ability of .pln files once loaded to the UI. Your work around works well in the mean time :+1: until the functionality what the UI is saying is there is added. Thank you

Voted! I’ve reported this bug I think three times since it occured during launch in August 2020. Each time it has just been marked as resolved, but I haven’t seen it actually being solved.

type in *.* to see all files in the Folder

But after loading a PLN File the AI Radio handling, ATC and ILS Approche get worse

1 Like

That is a nice tip too. What do you mean by the other related stuff getting worse? Are you saying it happens generally when loading .pln/.flt or just with .pln?

I can’t get this ‘feature’ to work. I can reveal, and select a valid .pln file using the Esc/Load route. Clicking OK to load a new plan is accepted and it allows me to go back to the flight and…the Garmin hasn’t changed the plan at all. It’s still the same one as I had entered previously. I created two different plans from the same location. Loaded the first with the flight, and then tried to load the alt one once sitting in the aircraft. Sadly no dice. Would be much better if Asobo just implement the ‘load’ option as a menu item in the Garmin, as Xplane does.