Pathetic some cannot even open the Sim cause of download looping or file not in MS store

I thought SU5 was bad enough.Like others I cannot even open the sim cause I’m getting the download loop…How on earth did this train wreck get released…Never experienced such a terrible state of a game.
I can deal with bugs within a game.When some of us cannot even load into the sim.There’s been NO word from the Devs on this.To at least say “we’re aware of this problem and working on a hotfix”
Goes downhill upon every update… :■■■■: :■■■■:

1 Like

It got released because it works, for most people, after they install the Xbox app, or whatever.

it got released because it works. downloaded perfetly fine for me

MSFS mentions that there is an update closes and goes to the store but nothing showing there. I presume I have the latest XBox App.

This might have just worked here:

  1. Go to the Microsoft Store and search for the ‘Xbox’ App.

  2. Download the ‘Xbox’ App and click ‘Launch’. (I had it already installed)

  3. Once the Xbox App is running, go back to the Microsoft Store to ‘Downloads and Updates’ and click ‘Get Updates’

  4. The MSFS update should start to download.

2 Likes

My purchase is through Steam…Problem I’m having and others who purchased through steam is…
The initial update via steam worked…When you load up the Sim…At 1st it was the 2.1gb patch…Problem is when the download reaches near %100 the download restarts.Then if you close down the Sim.Download goes up to 15.6gb.This has been mentioned on another thread.Which the further roll back to 15,6gb seem to work for some, not for all including myself…My point is a simple patch/download should not be this bad…

1 Like

I have the Steam edition. No problems here.

Not all but some who purchased via steam reporting same issues…I have no idea why this is happening…I’ve tried all the suggestions made over on the steam forum without luck…

I had the same issue. Steam. Frustrating to say the least. I turned off Computer a few times in disgust. Eventually, it went ahead and finished installing. No idea what changed. This is NOT acceptable Asobo.

1 Like

It’s not acceptable…it’s ok for those who had no issues to say “it worked for me its fine” My point is NO one should be having an issue downloading a simple update.I can understand if the issue was 1 person alone…Then that is clearly a personal cpu/xbox issue on their end…Said many have reported same problem…

4 Likes

It’s the MS Store that needs to be re-thought on MS side no doubt.

2 Likes

Maybe because some users are screwing around with their cfg. files and messing around with other things that they shouldn’t be. Then they come here crying, because the game won’t start.

That is insulting and demeaning.

As someone who messes with his config file and has a beautifully running sim this is an unwarranted and illogical assumption.

1 Like

Why are you even posting in this thread, if your system is running this game so great?

It’s Steam and exactly why I left them, I’ve never had an issue with MS store updates

Please refrain from attacking each other. Please treat each other with dignity and respect.

1 Like

I’ve said it before and I’ll say it again. This forum descends into childish insults from supposed grown men, simply because someone dares criticise or question the product.
People need to remember its a game. Not a cult. People are entitled to opinions but not to make churlish comments like a school kid in a playground.
Get a grip guys.

3 Likes

:man_facepalming:

Hi Chris…

You do know that’s not how it works right? Just because something works for you, doesn’t mean it works for everyone, or that if it doesn’t work it’s the user’s fault…

The download system is terribly designed, and poorly implemented. Put the blame where it needs to be Asobo for developing it the first place, and Microsoft for forcing them to push out builds before they’re ready and new DLCs to make money before fixing the bugs that existing users suffer from…

2 Likes

I’ve tried everything suggested still the same result…This looping issue has been around for months as some had this problem with SU4…Even official windows 10 said they cannot help.Needs to fixed by Asobo…What I currently have is a sim which I’ve invested $$$$ no longer works…That’s awesome…

1 Like