#pc - all kinds of problems trying to update

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
MS store

Are you using Developer Mode or made changes in it?

Brief description of the issue:
The update has become a total hassle, even for a patient, avid simmer, computer geek guy like me.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Try to update from Xbox. That didn’t work. Went to windows update to make sure nothing needed updating. Done. All clean. Went to MS App store, done. Xbox app didn’t need updating. Went to Xbox app to update, and no update available. Uninstalled Xbox app. Reinstalled. Rebooted. Tried again. Made the mistake of clicking “uninstall” thinking there was a choice to update there, perhaps in a drop down. No. Didn’t even get an “are you sure?” FS disappeared. Okay fine. I have a decent internet connection and no download limits. I’ll just install. . .again. But alas, no joy. Again, I get that “something unexpected happened.” sigh

PC specs and/or peripheral set up of relevant:
A monster PC. It hasn’t had issues updating since the last month, and I was a beta tester.

Build Version # when you first started experiencing this issue:
Trying to get past 1.21.18 and get 1.22.2 so I can get the world update. :unamused:

Did all this. . .

Microsoft Store - Download and Installation issues - Basic Troubleshooting – Microsoft Flight Simulator Support (zendesk.com)
(specifically resetting gaming services)
And. . .


(And @OrigBullethead poured out a libation for the electro-monsters that prevent such things. :rofl:)

And I think @TheSevenflyer linked those original “issues” in another thread, so thanks to him too!

Lastly, I can’t say for certain that all the things I tried actually fixed anything, as there is a good change that something was off on the server side of the house, and it just got squared away. :rofl: :joy: :rofl: :joy: :rofl: :joy:

Carry on.


Closing topic as the issue seems resolved.