PC Completely Locks up when loading into MSFS2020 requiring a PC reboot

Hello, since the Australian World Update, whenever I try to load into the sim, the sound will stutter, and my PC will completely lock up. The PC won’t respond, task manager won’t work. Only holding down the power button and restarting my system will finally get the game to load during the next attempt. Have reset Windows twice, and reinstalled MSFS2020 twice. This happens both with a full, and empty Community Folder. PC is not overheating, and this happens usually once I start my PC to play the Sim. My specs are as follows:

Lenovo Legion T5 28IMB05

Intel i7 - 107000 CPU @ 2.90 GHz

16 GB RAM (15.7 GB usable)


Windows, Microsoft Store, and NVIDIA drivers all are fully up to date.

Look through here Sound
sound ctd

Have you set a custom page file size, or is yours Window’s managed.
With 16Gb ram, very often a custom size is necessary.
Doing so solved that for me.

I’m assuming it’s Windows managed, as I haven’t messed with any configuration settings since I purchased the Desktop back in March.

I would change that and go to the recommended sizes for 16GB.

That helped advance the loading screen little bit, but as the Main Menu loaded up, the PC still locked up, requiring another hard PC reboot.

Here is a procedure that incorporates all the “fixes” I have seen here in the forum.
It doesn’t always fix the issue, but it has in several cases. You may want to try it.
There is also the “Support” tab at the top of the page.
It has several articles in there that may help.

Ensure all addons are removed from the Community folder, and any 3rd party plug-ins such as Navigraph etc., are uninstalled.
Remove any overclocks you have set up.
If you have used the Google map replacement, uninstall it using it’s uninstaller.
Ensure any third party antivirus programs (Avast, AVG, etc) are shut down.
Ensure you have an open path through the Window’s firewall.
Ensure all Windows updates are installed.
Make sure the time and zone in your PC settings are correct.
Sign out of the xbox app on your PC, and shut down Xbox app.
Sign out of MS Store App, and shut down same.
Shut down computer.
Unplug all controllers, except mouse and keyboard.
Restart computer.
Open and sign into Xbox app.
Open and sign into MSStore.
Reboot computer again.
Try sim.
Plug in controllers.

If you have a program for your motherboard that can check for current drivers, try using it. Even though Windows kept telling me that my sound card driver was current, it really wasn’t. Also, make sure sound “enhancements” are turned off.

1 Like

Do you think a driver update may have caused this issue? Thinking of reinstalling an older version of my graphics driver (pre Austrailia Update as the issue happened a few days post World Update) after I’m off work this a.m.

I doubt if the driver caused the issue, but it may help it.
I see a new update for Gaming Services, check the MS Store library to see if you got it.
Try the sim and see if that updated helped.

When you’ve gotten to the point that you’ve tried the fixes above, and none worked, in most cases I’ve seen, the one thing that does seem to work is a window’s system reset.

If you want to go that route, uninstall the sim, and delete all remaining folders.
Reset Windows and then re-install the sim.
There are some precautions to take so you don’t loose info on the PC you may have.

Believe or not, the older driver installation fixed the issue! Which is nice, ive been fighting this for months!

1 Like

That is great news :+1:
Good flights!