PC - Stuck in offline mode, all data options greyed out

I am on PC MS Store version 1.37.12. For the last few days I have been stuck in “offline mode”, and all data options are greyed out as below. I have tried signing out of MSFS, signing out of MS Store, signing out of Xbox app, and restarting, but it is the same. I have been playing since 2020 without seeing this issue before. Does anyone have any ideas?
Thank you

Maybe it is a network problem?

Is your router working
Is lan conected and running
If youre on wifi see if there is change in config

1 Like

Hi, there is no network issue with the rest of my PC

Hello @RebuffedBee9595

Thank you for your post! Your topic has been moved to the User Interface & Activities sub-category of the User Support Hub

If you would like other users to help you with an issue you are experiencing in the sim, consider these User Support Hub categories for your future post:

Aircraft & Systems
ATC, Traffic & NAVAIDs
Crashes (CTDs)
Hardware & Peripherals
Install, Performance & Graphics
Scenery & Airports
User Interface & Activities
Virtual Reality (VR)
Weather & Live Weather

1 Like

What where you doing last time the sim started up correctly?

1 Like

Have you ever been playing using the game pass?

1 Like

Thank you both for trying to help!

It will have been just my normal sim session, nothing different to what I’ve been doing last 3-4 years :thinking:

I believe I had the 1 month trial at launch in 2020 but purchased the game fully after that, and it has worked fine in that time.

One thing I have remembered is I have been running the SU15 beta since it started (and it was working fine). If this could be causing the issue I could uninstall it, but I would rather not until I have checked other options as I have slowish internet (10mb) so would take some time to redownload if it doesn’t fix it .

What you can try but not sure if this helps is rename userconfig.opt
In this way you have a backup of this file and the sim will create a new one
Maybe this solve the problem (sometimes it does but internet has to be working)

1 Like

Done this and now its staying on the loading screen with blue loading bar at 100%… Exited and tried again and have the same. Task manager shows 1% CPU usage and 0% disk usage, I don’t think it’s doing anything. I feel this is not a good sign :sweat_smile:

What does your network load do in taskmanager

1 Like

Are you on disk version or store version?

1 Like

In windows,
Are you blocked thru firewall check if it has permissions to connect to internet

Also scroll down and see if xbox have permissions

1 Like

-MS Store version
-Task manager showing 0% network utilisation, still on this loading screen
-flightsimulator, xbox, microsoft store, and microsoft flight simulator all excepted on windows firewall

It is very frustating as it is, but is your browser working?

1 Like

My internet browser? Yes my internet connection is fine

Have you report it to zendesk yet if not, you can do so

Im running out of options here but this is where im thinking

My guess is that there is aomething wrong with xbox app or related components
You can try to delete these xbox components from playstore app and redownload after uninstalling
But you probably have to sign in when redownload and starting up
So be aware that u use the right sign in of your account which you use for the sim



1 Like

Did you ever just unplug or reboot the router? I find MSFS gets connection problems limited solely to MSFS when everything else works fine. I do it once a week old school style. Plus windows just got an update a couple days ago.

A download in Xbox or a laptop comes in at 850mbs, but in game 3mbs. Unplug and hard boot it’s back to 200+. There’s something strange about the way the game handles downloads almost akin to the way it handles persistent data.

1 Like

Hi guys, thank you for all your suggestions. I believe I have isolated the problem to one of my ISPs which is Talkmobile in the UK.

I have now found this other thread where a user had the same issues, and also used Talkmobile. I have done further testing with other ISPs and repeatedly find the issue with Talkmobile only, I have posted my findings in the other thread

1 Like