Pelican controls

I can’t find a way to open the cargo door on the Xbox version. Can anyone else do it and see that switch working? Setting the autopilot heading or altitude doesn’t seem to change the pink numbers either.

practical 50-54k but need same trick like with darkstar after some alt revert and go after 1m then it takes about 1.2m after 53 it’s too slow airspeed and you can not take neutral aoa without vs go down, so your mach number go to 1.19 and airspeed slow down faster, then you go with ~0 aoa down till overspeed do loop high yo-yo lol and it’s go 60+ in higher point. but for sure you can fly comfort horizon at 52, with less fuel 54 or even some higher

Are you using the pc or Xbox and getting the cargo door to work?

There’s usually a trim wheel with a line at least so you can see the take off position for example.

Is the input panel community mod on flightsim.to? I will have to look into it. Thanks!

Trim control is on the starboard control stick. I assume there’s a feedback number if you’ve enabled Tooltip labels in the Accessibility settings.

Oh really? I did not look there. I’ll check it out tomorrow. Does it look like it has any indicators of neutral trim? Thanks for the tip @DashingLeper

Pc version…the button is on the switch panel top right side of the cockpit, it the bottom left one of that group, also if you click on the numpad on the doors behind the cockpit, it will open the internal doors to the back as well.

Hi I play on Xbox with a controller does anyone know how to turn when in hovering mode in the pelican

1 Like

In hover mode you dont turn you yaw, stick left and it will move to the left pointing forward, if you want to yaw left or right use the whatever you use for rudder pedals…now the craft will swivel left and right ie yaw, and if you want some real fun combine both of these for some real great maneuvering, to bad the gun dont work ;p

To turn in hover, you use the rudder to yaw. The stick simply does translation. You cannot bank in hover mode.

Two ways to activate hover: There’s a switch above the landing gear light you flip to transition.

Second way: Map a hotkey for Toggle Afterburner.

On other stuff, the engines draw fuel from the forward tanks alone. The rear tank is there to refill the forward tank as the forward tank empties under use. Be sure to activate the crossfeed knob (between the fuel valve knobs) to top off the forward tank.

I believe so. It’s the only site I’ve used so far.

It’s very useful. It’s also good to make sure your inputs are all working correctly and some airplanes don’t have a good visual on trim. I hate the popup labels in VR. They’ll often cover things you are trying to see. So I always have those turned off.

Thank you - did a complete reboot and it’s working now.

Is there a manual anywhere?

Pat

I can’t seem to get the bird to yaw in hover mode. I see the pedals depressing but she won’t turn from side to side. It cruise mode, the yaw works normally. Anything I’m doing wrong? I turned off all the AI assists, no change.

Hi

Does anyone know how to map the cargo door switch to a button? Witch function in the setting is it? Thanks.

I think this is a bug. It doesn’t happen if I start off either in air, on cold on the ramp. If I start off on the runway, then I can’t yaw in hover mode. I can yaw in cruise mode, but if I switch back to hover, it’s locked again.

you are off the ground when this happens right? wheels up? left right should slide you left right, forward back do just that, and rudder pedals should yaw you left or right. Until you switch to horizontal mode then it flys like any other plane.

I finally got mine to be able to turn on hover mode. If I have the landing gear down i can turn. I don’t know if anyone else had this problem, hope it helps.

Yes, off the ground. No yaw. If I go into cruise mode, I can yaw. If I return to hover mode, locked in place. This only happens when I start the flight on the runway. I wonder if there is some precheck setting that doesn’t get done in this mode.

Yeah thats weird. I have all controls in either mode no matter if I start cold and dark, or on the end of the runway. So I just checked my setup and twist on the joystick (rudder) is set to rudder axis with reverse axis checked. And stick left / right are set to Aileron Axis with reverse axis check. Nothing else so look and see what you have for those 4 fields and if its anything try changing them.

Now that Im thinking about it, do you happen to have any of the assists in the menus checked? Might be something there as well. And last but not least check to make sure flight model is set to modern in the general options menu…