Pelican won't turn in hover mode

I can’t get the pelican to turn (yaw) in hover mode. I see the pedals moving when I use my rudders, but ship won’t turn. Assists on or off make no difference. In cruise mode, rudders work as expected.

works for me… But then again I also mapped both rudder and nose wheel steering to the same controls. Maybe you can try that?

You think it has to do with the nose wheel? I can give it a shot I guess

I dunno, I’m just spitting out ideas…

OK, the nose wheel thing doesn’t work, but I have discovered that it only seems to be an issue if I start off on the runway. If I start at a parking spot or in air, the yaw works.

Ahh that makes sense… I never start any aircraft from the runway, so that’s probably why I never had such issue.

I tried this with limited success. Some parking spots still have the dead rudder problem on some of the airports I’ve departed from.

In addition, if I start in air and touch down at an airport I lose rudders when I take back off.

Submitted a ticket via support. No acknowledgment yet to my knowledge.

That’s an interesting thought. Maybe I should try a different airport. I’ve tried the two local airports that use 99% percent of the time I play the game, and I’ve never had rudder issues with other planes, but who knows.