Performance drop 15-20% after World Update 3 (1.13.16.0)

Its not the best pair no. Currently saving up for a new CPU and motherboard. FS2020 sure is an expensive sim

I retried it today. My favorite city is Montreal. Now it is a giant stuttering mess. There seems to be less tearing with Vsync off but still unbearable. The dynamic cache does nothing since flying back the same area produce the same effect. And yes, the manual cache is still out of service.

I will quit playing until Asobo get their mojo back. Somebody screw up big with this “update - downgrade”.

1 Like

Would also recommend 850W PS.

For RTX 3070 650W is good enough.

Sure - speaking for a 3080. Recommended is 750 but I’ve found that a bit of extra is needed. Im on EVGA 3080, AMD 3900xt

Hey all – someone on one of the Facebook forums posted these tips to me… at first, I rolled me eyes (I thought I knew it all, lol) and yet I went ahead and did them… and guess what, my FPS has gotten much better and back to where it used to be.

I am still testing, but spawning in KDFW has gotten me back to about 25 fps (vs 5 yesterday). I also spawned into EGLL and have 25fps in A320… THANK YOU Chris Blackwell.

I am posting his tips below – use at your own discretion – hoping this will be a workaround fix for those of us who have seen major performance hits this week.

(my culprit – I checked my Windows 10 power settings and it got reverted to normal vs prefer maximum power - so I changed that immediately… I also did the NVIDIA options he suggests below and I think this helped, too. Plus turned off all Xbox Game Mode and Accelerated GPU as it just doesn’t seem to do anything. Also, for first time ever, I have Vsync in Nvidia Options on, whereas I have never used it before – no idea if this helps too)

Again, hope these help – I did not mess with step 1 – too complicated for my taste.

7 Likes

He means Task Manager in his final recommendation, not Control Panel.

1 Like

I thought/heard that any settings/changes in the Nvidia CP doesnt have any impact in the sim? Correct me if I’m wrong

@moxiejeff

If you want to see the same, and more, but illustrated… :slight_smile:

My 2070 SUPER 4K settings and suggestions - episode 2
My 2070 SUPER VR settings and suggestions (Index - SteamVR)
My 2070 SUPER VR settings and suggestion (Reverb G2 - WMR)

NB: the first in the list is due for a refresh I wanted to do with WU3, but given the state of the release, I’ll wait for SU3 instead.

2 Likes

Performance when using pop out instruments is dreadful compared to before the update. I can dip down to single digits now. Had to do some serious tweaking (lowering) of settings to maintain a usable frame rate on my Ryzen 2700X + RTX 2080.

2 Likes

No idea… but it worked for me

Thank you @CptLucky8

1 Like

Doing these steps also seems to have fixed my issue! Thank you so much for sharing!

1 Like

Desappointing.

I bought (probably other simmers as well) a new PC precisely for the new FS with the ideal specs to enjoy the game at the max.

At the released, it was faboulous.

Now, the more they “improve the game”, the more the fun experience decreases.

I’ll stay optimistic in hope they fix things.

6 Likes

UK and Ireland actually… but yeah :grin:

So here’s my issue. Was doing a flight this afternoon (1st once since the patch) and was using the WT CJ4. Flying from SAN-DEN without any issues. During cruise, my fps suddenly dropped from 70-80fps to 19 and just stayed there. Went to external view. Tried windowed/full screen. Everything just went straight to c-rap. Was extremely frustrating. I exited the flight and went back into game and my fps were normal. This has got to be something with the patch.

2 Likes

I think its a VRAM memory leak. I have constant 7 to 8 GB RAM usage with my RTX 3070 all the time after World Update 3. Before it was at least 0,5 to 1 GB less usage.

3 Likes

I have the same issue… Dropping from 50 fps to 18 fps sometimes. After a while back to normal. During the 18 fps, the GPU usage is only round about 35 %. Normal it is running between 85 and 100 % … A 1080… There is definitly a leak with the video card code …

greets klaus

1 Like

@moxiejeff, my issues are still unresolved. I’m in the process of removing all of my add-ons from the community folder as I think in my case that might be an issue. I noticed when I deleted mkvy’s EGGK - Gatwick package things were more like normal. I’m also going to install a mod manager in hopes of preventing issues in the future if all this works.

Yes!!! I think this could be it too. I’m no expert in this field, but I noticed my RAM was basically completely used up where previously I had a few to spare.

1 Like