Persistent Failure of Decompress

I am a MS Store user with no add-ons. Clean new install of WIndows 10 with all updates.

Brief description of the issue:

PC specs for those who want to assist (if not entered in your profile)
ROG Strix eGaming II MB (on offending PC)
Intel Core i9-10920X (X-Series 12 cores)
64GB RAM
ASUS TUF Gaming Geforce RTX 3090
NVME “storage drives”

The below described problem is not at all with installing the software from the MS Store. The problem is with downloading all the content within the Sim.

I first installed on the computer I was building for the office which requires nearly identical functionality.
The only difference is that PC uses a ROG Rampage VI Extreme Encore. All processor and memory etc. is the same.

On the Rampage system the whole game installs without any problems. All the downloads, updates, etc. work wonderfully. No problem with download, no problem with decompress.

On the system that I am going to take home (Rog Strix MB) I get chronic Decompress failures. No problems at all with download it will just hang on various Decompress. It is not particular whether it is a small download or a large one.

I tried using 7zip from a post I found on a blog. 7zip had no problem decompressing the files that failed.

In the end, I wound up creating 7zip files from the fully installed system and then putting them in the “Onestore” folder on the system that was constantly failing the decompress. I just couldn’t keep restarting 65 GB downloads and ever expect to get it to finish in a reasonable time.

I’ll find out on Monday if the game works as I’ve just finished this morning getting it all on. I’ll give it a go when I get to the office on Monday.

I suppose I should suspect a problem on the system that exhibits the problem, but I’ve found nothing else malfunctioning. I’ll have to continue using that system to see if other things fail. As it is a new system and not used much I’ll have to wait and see about this.

I don’t want to put the files on the C drive because it is only 1.5 TB and given all the space FS takes I’m certain that would turn out to be an issue at some point. The D drive is 6 TB.

I have had the exact same problem for months, and nothing has been done to correct it. At home when I unzip the files with 7zip there are errors, it tells me that the files are corrupted.

The only way I know to deal with this is continue to restart failing downloads.

Apparently I’m lucky enough to have a nearly identical system that works fine that I can copy from. I hope I find that actually works when I try the Sim at the office.

I hope they will release an update for that, there are people who have had this problem since the game was released.

Exactly the same Ram in both? (Brand, speed, timings etc?)

Swap the ram over OR check the timings on the rampage rig.
Possibly relax the timings a little (step back from the xmp profile and run the ram at its slower default)

Then try a decompress again.

Exactly the same components accept for the MB.
Corsair VENGEANCE® LPX 32GB (4 x 8GB) DDR4 DRAM 4133MHz C19 Memory Kit
SPD Speed 2133MHz

These were purchased in 4 32GB sets, 2 sets installed on each MB. This memory is on the tested list for these boards from ASUS, and were purchased in sets as per the ASUS stipulation.

Neither board is overclocked “by hand” but only with the built in ASUS “AI Tuning”. I suppose I could manual turn off all tuning.

It is quite strange as both MBs run the same firmware, same chipset, same processor, etc.

Are they using the same bios on both boards? (I guess that even with slightly boards/bios they may offer the same control over memory timing. )

I would definitely try testing with the memory at its stock jedec timings to eliminate “manufacturing tolerances” of the memory from the equation.

I had similar problem, CTD during decompression. I then disabled ransomware shield in my antivirus, and this solved my problem.

Same problem here…trying to install that game for more than 1 week… -.-

I have an ASUS ROG Board as well.

It is not surprising at all really. These are ASUS ROG MBs the fairly recently support the Intel x299 chipset product.

Not surprising at all that they run the same firmware, the same bios, etc. Clearly these are 2 different MBs and of course they may respond differently. Using the same chipset, supporting the same somewhat “new” Intel X299 processors…

I built the ROG Strix X299-E Gaming II MB first, and the memory was first 32GB (1st set of Corsair memory ordered/delivered). Then a couple weeks later I ordered another set of Corsair same 32GB memory then installed. I followed the ASUS direction to get all the same memory modules in a set for each memory bank set. All was done with approved ASUS memory mfg/part# and sets.

Subsequently I built a nearly identical system, the ASUS Rampage VI Extreme Encore X299 MB. Both systems were OS installed at the same time because I was waiting on ASUS support direction regarding NVME storage configuration.

I chose the Rampage because we have a “gold plated” err very expensive Lidar scanning system at our engineering firm whose software requires substantial processor and GPU requirements. I selected the same TUF ASUS NVidia GeForece RTX 3090 Graphics Board identical to the same graphics card installed on the ROG Strix MB system. However I had originally installed an ASUS GeForce GTX 1660 Super OC EVO Edition Graphics Card 6GB GDDR6 graphics board on the Rampage (much inferior to the RTX 3090), but we had that Graphics Board at the office before we received the newer ASUS RTX 3090.

The Rampage MB installed/downloaded/decompressed all aspects of the SIM and World Updates…

That the Rog Strix Board system hanged on multiple and random package decompressions is remarkable to the extent that it is likely obvious there is a problem with the SIM code because 7zip had no problem whatsoever decompressing any of the files.

Sure there may be a corruption or CRC discrepency, but the SIM update should absolutely deal with this issue without HANGING.

Frankly I have a work around because I can copy the install from the nearly identical system. I most regret those very important users who do not have a simlar working system to copy.

This is ridiculous. I will swap memory modules with the system that works to prove that is not a problem, but I very much doubt that is the issue. I think there is a serious problem with the software. The software should be robust enough to deal with file copy, compression, expansion issues so as not to HANG the software. Very disappointed in the MSFS gods. After all they are working for MS… they must be gods or godesses.

Too many people have this problem for the issue to be a specific “hardware” problem.

For testing purpose uninstall Asus software and AV.
Restart system.

Launch msfs as administrator.

Well, I’ve not uninstalled ASUS software, but there is only Windows Defender, and I was logged in as an administrator.

Thanks for the suggestion.

@QuadRapier91626 you’re a hero, that did it!

Been fighting the install for days and now as per your suggestion turned off Ransomware protection (AVG Free) and the install pulls through!

Right click on msfs and selecct run as administrator.
image

glad that helped, don’t forget to turn ransomware shield again after install.

Maybe someone more knowledgably can tell me how the below makes sense.

This is how I get into FS 2020:

Update screen opens - two items are listed flight-tutorials-departure and a level flight tutorial. Departure downloads and then craps the bed when it decompresses.

I close FS 2020 then use task manager to kill Steam.

I open FS 2020 again.

Update shows less to download. It gets stuck on decompress again. I repeat the closure of steam and FS 2020.

I open FS 2020 again. Less to download. Gets stuck again, this time decompressing the other file.

Close every thing again.

I open FS 2020 this time 0/0 of items to install, but it downloads everything and installs it. FS 2020 launches.

Ransomware is turned off. I have no idea what is going on and no idea why the above works.

I have to say it is really annoying to waste 20 minutes trying to get into the game.