Persistent Stutters

ok, I think after some testing I am getting close here. I reset my Nvidia CP settings to where they were after patch 2, when I was getting the smoothest experience, but still getting stutters (mostly turns on external view, when scenery loads).

I tried everything mentioned here and nothing worked, but I found an old FSX/P3D post with a mask affinity calculator that you post into the .cfg file. I have always thought this is a CPU-based issue and that is why I think it is linked to i7 CPU’s, as most people seem to be experiencing these issues with i7’s.

I have no thermal throttling issues, as my GPU rarely gets above 73c and my CPU generally stays around that as well, but I did notice cores 1 and 8 (I turned off HT in BIOS) were always running at 90%+, while all the others were not really being utilized. I set my mask affinity to isolate those two cores and unbelievably, it is SO much better! It is not perfect and I still get some smaller stutters, but it really helped me a lot!

I mostly test around Denver, but also did in NYC (newark to LGA and back) and it was much better… I think there is an issue with my CPU that I haven’t fully figured out, but I think that is the culprit.

i need to tear my gpu apart and clean it. I’m sure it’s dusty as hell.


RTSS = Rivatuner Statistics Server.
It’s an utility. You may want to use it with MSI Afterburner.
That is a “vga tuner” program too, what is monitoring your fps, gpu temp, cpu temp etc during play.
It can also manipulate the performance of the vga.
As far as I know, when installing MSI afterburner, you can also choose to install Rivatuner.

Scanline sync is an option within Rivatuner:

You can download MSI Afterburner here:
MSI Afterburner

1 Like

Because of a funny misunderstanding.
When you wrote: “use RTSS scanline sync x/2 -1”…I thought x / 2 meant half of 60hz.
I set the fps to 30, subtracted one from it and the -29 was ready. :grinning:
So in retrospect it was stupidity, but it led me to the Holy Grail. :metal:t2:

one reason
whats your internet speed - i get more stutters if internet is either too slow or its intermittent due to a fault
ive had similar , theyre last patch improved things but it would be great without the stutters

Mine is 50mbps.
In game options bandwith set to unlimited and rolling cache off.

LOL I think Persistant Stutters would be a great name for a punk band .


How did you find the draw distance? I can’t seem to see that in the user cfg?

in the user.cfg, it’s under Terrain LOD

I solved my microstutters by disabling a services called “Distributed link tracking client properties” and “Connected user experiences and telemetry” in Services.msc.

I think MSI AB and the FPS overlay was causing my stutters. I am no longer using it and I’m making sure Riva Tuner Statistic Server is not running. Since I started doing this I have had three long consecutive stutter free flights with the A320. I also set Vsync to “use the 3d application setting” in Nvidia panel but I believe the latest didn’t have anything to do with the improvement. I believe it had to do with the Riva overlay, at least in my case.

well all, I very much appreciate the advice. I have tried everything in this thread and everything on these forums. I still have persistent stutters when terrain loads to the point the sim is just not fun anymore. I think it may be my CPU, as I feel like I have ruled everything else out. I think I am going to hang it up. Thanks again all!

I too tried every suggestions in this thread and other threads. I still face stutters.

I have a i7-10700, RTX 2070 super

I feel like it’s the i7. I swear the majority of posts with problems all have some i7 CPU.

It’s not your CPU, I was having this on my Ryzen also. I have a 2070 Super. Last night I finally fixed this (for me anyway). I posted this on another thread but I’m posting it here also just in case it will help you.

Previously I was locking the frames at 30 through Nvidia control panel because Vsync appeared to be broken in MSFS with the original release version. I was turning off Vsync in MSFS. This worked really well but I was still getting some micro stuttering occasionally.

Last night I discovered that MS may have fixed Vsync issue. Determined to rid myself of microstutters, I set Nvidia CP to defaults except for preferring High Performance. I removed the frame rate cap. I then I re-enabled Vsync in MSFS and set it to 30 fps in MSFS.

It is so smooth now. I don’t see any stutters. This worked amazingly for me. I was floored last night. I hope this works for somebody else.

I tried your suggestion. My FPS is now in the teens, does not go over 20 FPS. Am I doing something wrong?

My solution probably won’t work for everyone. I tried so many things to get to this point for me. In Nvdia control panel, do you have it set to allow application to control Vsync with no frame rate cap?

I am using version 452.06 of Nvidia driver.

To get to the root cause of this, I did the following…

-Ran tests with only clear weather
-Disabled all simconnect programs
-Killed all non-essential background tasks and programs
-Flew with basic steam gauge planes only
-Disabled all multi-player, AI traffic, etc.
-Set all of my msfs graphics settings to modest sliders (100), high, no ultra
-Enabled Windows 10 Game mode
-Enabled CPU scheduling

Now I will start adding stuff back to see how it goes

Excuse me for interrupting but do you have an SSD or hard disk.? I don’t think you mentioned that.

That’s how I’ve been running it since about a week after the release.
It’s smooth and stutter free in all but the most taxing areas like the Charles de gaulle airport . Also means my GPU is running at about 70% so the temps stay lower, plus I have more GPU headroom for turning up the visual quality.

i have a ssd