PFD freezing on Approach in TBM - Not seen before latest patch

Hi guys. I’ve got 170 hours in the TBM in sim, and since the patch, I’ve now encountered a situation where the PFD freezes on approach. No artificial horizon info, no airspeed info, no compass info, no altitude info. I still receive DME info re: whatever ILS/VOR frequency I had previously entered, but I’m forced to rely on the standby instruments for altitude/airspeed/artificial horizon info. This is a NIGHTMARE. Both times, it has resolved once the TBM enters into APR phase, which is weird, because that is now happening by itself (the NAV source button is now switching from FMS to NAV1 without me telling it to do so, another issue). Once it does that the PFD comes back to life. But for a sim nerd who flies by the book, I’m deeply frustrated. I’ve checked the boards (and maybe missed something) but I’m not seeing this exact problem and as I said, I’ve flown all over the place, IFR, in the TBM in this sim and this is the first time I’ve encountered this problem, and couldn’t help but notice it happened twice today, since the latest patch. Any ideas?

4 Likes

This is the behavior I’m seeing in the C208 on approach. Once ATC notifies of the approved approach, instruments on the PFD freeze, no altitude, no speed, nothing. I can still use backup instruments until fixed on the localizer, then all functions go back to normal. There was another thread that mentioned turning avionics off/on and selecting various AP secondary functions as possible workarounds, but I haven’t had the opportunity to try.

1 Like

I have had this problem since 1.9.3.0 on the TBM-930. ATC gives instructions to descend. I lose the altitude and speed indicators with no ability to change using the Altitude Select knob or Vertical Select Wheel. I end up hand flying the plane to my approach altitude and engaging the Approach once I have Loc1. As soon as the Glide Slope engages the instruments come back.

2 Likes

I had the freezing problem since 1.9.3. Once it freezes, it’ll unfreeze at the next approach fix point in the flight plan. There are ways around it. Either fly manually using your backup display, the tiny screen until you get on the localizer. Or sometimes it’ll unfreeze if you cycle your flight plan with a quick direct-to selection of any point of your choosing. I just deal with it until the plane hit the next waypoint and unfreezes. Usually I already have my altitude and decent speed set for descent to hit glide scope so i just patiently wait.

1 Like

A workaround is entering the flight plan manually, in 4 flights after entering manually, the PFD has not frozen. Not ideal, and certainly not for long flights, but it works and is repeatable. I have not tried saving the flight plan and reloading, but that’s next. I like the idea that @SirePanda13 mentioned, but I haven’t taken the time to try selecting a different Direct-to for the unfreeze.

Update…it froze again :unamused:.

What I have found that worked once (I read this fix on another thread) was to simply not include an approach in the flight plan. I did this once and once ATC assigned the approach I selected the approach from the MFD, and it worked flawlessly. I will attempt to replicate it a few more times.

1 Like

Im getting the same. Unless i dont use fmc. Then its ok.

Same issue here.

I fly the TBM930 and have the same issue on most of my long-haul flights. I’m on 1.9.5. version as well. But I’ve found a workaround (it worked for me…once).

  1. fly according to your flightplan
  2. nearing destination when your PFD freezes, look at your MFD
  3. click Procedures
  4. click Approach
  5. select the Approach you want (anyone doesn’t matter)
  6. LOAD the Approach
  7. your plane will probably do the dog leg to line itself up for the approach again. I’d rather this than have the PFD freeze on me.

Try it. Hope it works for you.