Pilatus pc-21 (deimos inc.) XBSX

Causing CTD as soon as you try to load for a flight. Cannot find anything online regards contact to report this?

Are you running in DirectX 12?

Hi there, the plane has been tested so long from us and also by the guys of microsoft, and no one ever had ctd.

Just to double check, try to unistall the plane, reboot the game, install the plane again and re-boot again the game.

For any think, you can contact us via mail (you can find it on the plane’s page in the marketplace).

Please let us know!

I’d try deleting rolling cache, even if it’s turned off. For some reason that has worked for me in the past when I’d get that CTD at flight start.


Update for you:

When doing a random flight from mid air it is ok, when i load from Gatwick for example CTD.
But after doing the random flight for 20 mins, tried Gatwick again and it was ok.

So i do not know what is actually causing the issue.

1 Like

Copy that thanks!
Btw, for my personal experience… when you have many addons… once there is the SU or many updates of the packages… is much better to perform an hardreset of the game and re-install all… i know it’s a mess … but actually i feel the difference

will keep that in mind, hope Asobo will improve stability for next update as i believe they are concentrating on this for SU9.

Same issue on series x

I have the ctd issue on series X, first time of the session it works fine, but it usually will crash the game if you load in to a second flight during the same session. The problem is repeatable and only occurs with this aircraft.

Also if you use the new turtle beach velocityOne, the elevator trim is reversed, though in settings it indicates it is not reversed, multiple people in the VelocityOne discord have had the same issue on series x.

Moved to #third-party-addon-discussion:aircraft

About Xbox the plane has been tested by microsoft and they did report nothing about that, as well as for the trim. The trim as well is working in the same way bot for xbox or pc so i have no idea way on that koystick is reversed.

Btw we’ll go trow those things and will try to find a solution.

The trim issues only affect the VelocityOne, they seem fine on other devices. The crash issue is the only one that makes it hard to use the plane on an Xbox. On pc it has not happened to me.

If you have static scenery add ons installed, it can cause weird clashes. Yes even with specific aircraft. If you have several, The only way to find out is the hard way. If you havent tried a fresh install, it sucks but will probably fix it.

No addons other than the aircraft, I found another plane with the same issues and both are made by the same developer. The other one is the Felon.

I see this was updated in the marketplace.

Does anybody know what exactly was the update ? (I don’t own the aircraft, so I cannot take a look)

Not long had this aircraft and loving it so far apart from a couple of issues. Has anyone else experienced the loss of screens about 20 mins into a flight? I find that for some reason the battery switch has been turned off. It all comes back if I switch it back on and the no further issue. Secondly has anyone had a total loss of control by simply scrolling out on the VFR map? I have been able to replicate this each time. For the time being I can cope without doing this action but it is a little annoying. Any help or info on updates would be greatly appreciated.

i am not sure if this is modeled in this aircraft, but batteries are not supposed to stay on
after enginestart, the engine delivers the juice now, you DO need to switch the alternator.
maybe try that?

Hi there,
just bought this plane and it’s quite nice though found a few issues that are a bit annoying.
Elevator trim is working just fine but aileron and direction trim are not working. The plane is leaning to the right in flight even wihtout wind (due to propeller ?) but I can’t compensate with trim so I need to maintain rudder through the whole flight which is not very comfortable…

I’m flying this on PC with HOTAS (warthog) and rudder pedals (logitech).


Due to an error by the manufacturer of this model, it is not possible to get glossy paint on the model. the texture responsible for the shine is incorrectly assigned. In this texture the intermediate areas of the rudder elements have been fixed. However, the texture should cover the entire area of the exterior model.( FUSELAGE_FUSELAGE_HEIGHT.PNG.DDS)

There is no roughmet or hight texture assignment for the pilot. I’ve tried umpteen endings with no success. In addition, the quality of the paintings is poor.