Pink (missing) texture - is a partial reinstall/repair possible?

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it?

Brief description of the issue:
I appear to have missing corrupt material/texture files (CEMENTDIRT01) as areas using it are showing pink. The actual file referred to is ASO_CEMENT01_ALBEDO.TIF.DDS.

Would it be possible to delete [Core Content/Mandatory Packages] from Content Manager then allow FS to re-download it?

Build Version # when you first started experiencing this issue: possibly the version before that.

Are you on the Steam or Microsoft Store version?

Did you submit this to Zendesk? If so, what is your ticket #?

It certainly should. I have had a number of problems updating packages before. The Carenado Seminole was one. I shut the sim down, deleted its folder, and when I relaunched the sim I could download it successfully via the Marketplace.

Before you try the following, are you sure you don’t have a conflicting airport installed? I’m sure this pink texture thing rings a bell, and its possible you have two conflicting objects installed. I’ll try a quick forum search…

In one, it was reported removing the third party scenery fixed it. In another Hester has some advice:

For core content, I found a folder that appeared to be empty apart from its layout, and manifest files, called “microsoft-event”. I guess its a placeholder for something. Out of curiosity I deleted it, and when I relaunched the sim, it prompted to re-install it, just like when we get the updates.

The file you mentioned is in the path:
Flight Simulator\Official\OneStore\fs-base-material-lib\MaterialLibs\Base_MaterialLib\Textures

The textures folder is pretty small:


In fact, the top level folder “fs-base-material-lib” is the same size.

I would imagine it would be safe to rename the folder “fs-base-material-lib”, then launch the sim to see if it will selectively pull down all the missing data. You have the renamed copy as backup.

Hi - thanks for the info. I’ve followed some of those links before, but not all of it applies as I still get the issue when no other airports (or mods of any kind) are active, so …

… your suggestion of renaming the materials folder sounds like the least dangerous thing to try (first!). Thanks for that - watch this space!!!

EDIT: Well … I renamed the materials folder and relaunched. MSFS correctly updated itself and a fresh copy of that folder was duly installed. Another restart … and … still I have the pink stuff … AARRRRGH!

1 Like

Closing as a duplicate topic. For any “pink” or “purple” tiles, please use this topic:
Thank you!