Plane not following/aligned to red line (GPS path)


I have never had a problem with the planes following the GPS path (red line) until the most recent update! I have AP, NAV on, GPS on as I always had. Plane always followed perfectly the red line since August 2020! After the update, for all flights I had, planes never been aligned with the line. Can anybody help me?


Need a bit more information but I suspect you have selected a start and finish on the World map and selected VFR.
What waypoints were listed in the flight plan and was there one called APPDATA ?
Try the same thing and select IFR , Low Altitude and it might follow the line.
If it does this is a known bug.

Did you select the “GPS” navigation mode and set the autopilot to NAV-mode?

On which route you experienced this problems with following the GPS course?

I’ve done a number of flights now and I can confirm that on GPS navigation it does not follow the direct path between two waypoints but veers off to the left or right like the screenshot above. This since SU5.


This is because since SU5 the world map flight planner actually adds waypoints which are not visibly represented with the magenta course line.

Your aircraft still follows the actual course but it appears as though there is an offset between aircraft and magenta line in the Asobo mapping.

I use SkyElite which pulls the full course data from sim using SimConnect for its own moving map. There are clear waypoint/course differences.

You can see a 2d representation of the waypoints in NavLog tab in world map flight planner.
You can not delete these waypoints and they will also cause all sorts of strange routing issues if you try to create your own VFR direct route by adding your own waypoints.

Basically SU5 broke it.


The problem for me at the moment is that the autopilot flying the GPS track will not fly towards the destination. I’ve now had several instances where it will fly past the final destination waypoint i.e. many miles either left or right of the waypoint. GPS navigation is basically useless at the moment.

1 Like

But have you tried an IFR , low altitude route as suggested before ?

Darth is right. GPS navigation is useless after the SU5 update. I have tried many GPS flights on NAV auto pilot and it won’t not only get me to the destination it will fly me further away from the destination than your starting point. I took a short flight from Ft Lauderdale to Naples FL this afternoon which is a heading of about 270 degrees and the GPS heading was 90 degrees, the polar opposite.


Yes same story irrespective.

Works for me. Which plane / GPS? Screenshots help to better troubleshoot your problem.

I was about to create a new topic when the forum alerted me to this existing topic.

I am still seeing this problem. There is an offset when it comes to tracking the GPS magenta line. This screenshot is from a flight yesterday in the Citation CJ4 but I see it in small planes too like the C172.

Screenshot 2021-10-16 031238

Oh I see, nice to know a reason at least, thanks for explaining. I hope the next patch fixes this.