Please help after 7 hours of installation i'm here

Hello there,

today i decide to format my drive and do a new windows installation.
All ok, in 30 minutes i was ready.

At 10.30 am i start to install FS2020.
now its 5.30 pm and after 7 hour i’m here…

my connection is pretty good, and I think this situation is disturbing. And it didn’t happen during the first installation in August.

any ideas?

It does happen that it gets stuck, if after so much time it is does not continue, you can exit (ALT+F4 to terminate the application) and re-launch - if you restart it should pick up where it stopped but might need to re-download the file fs-base-cgl-0.1.21.fspackage.021…

there is an obvious problem, because every time a package finishes, the installer downloads it again instead of going on

For each package it takes somentime 5 minutes sometimes 20 to 30 minutes sometimes 1 hour
see screen
is absurd!

and now after 12 hour from installation start
this happen

In regard to the last error message, please have a look at this article to see if it can be of use.

the problem is in the DOWNLOAD system!
I finished downloading the FS Base after 22 hours !!!

And now in the content manager I can’t finish downloading the Japan USA updates and not even the planes!

what the hell are they doing !!! !!!

Another exsampe of this Fuc… situation!!!
Sdk installer,look at the speed from Microsoft, Azure o whatelse server…

For sure smthing is wrong with the game itself, i did fresh reinstall and ended up a320 and 747 instruments displays being blank only happens after reinstalling the game tried multiple solutions with no luck… the 787 works great.

I read your frustration and hope you could get further soon; I think it needs to be checked why the Internet connection to the content servers are so slow. Your screenshots show an extremely low transfer rate and regardless of what you are downloading in relation to MSFS it looks like it’s stalling and hangs or fails. Do you download other games, is it only slow with the Microsoft content delivery servers?

What about if you download other updates from the Microsoft Store? What’s the speed there?

Hi,

I smoothly downloaded Battlefield V and World of Warcraft in a few hours. So it’s not a problem with my pc, or my internet service provider.

The problem is the servers from which I download the MS2020 files.

Often the download fails, the speed goes from 55mb / sec to 0.5 sometimes download sometimes not … more than 24 hours have passed since the start of the installation. This is crazy

take another look

Have you tried this?

Since Saturday morning I have had server errors from Microsoft again and again that goes as far as it even disrupts the network connection as soon as MSFS is not running the problems are fixed.
I had an update from XBox App on Thursday, I don’t know if that’s the reason, I never had any problems with the connection

As per a current Xbox tweet:

We are aware that some users are experiencing issues while attempting to purchase in-game content and attempting to matchmake in multiple titles. We are currently investigating and will update here, and on our status page as we gain more information.
xbox.com/status

The issue will probably be more looked into during the week.

At the moment MSFS is not possible to fly there is also CTD since Saturday I have no other CTD but since Saturday 9 CTD on 10 flights.
from my point of view there is a bigger problem with the servers.
The CTD are different you can fly for 3 hours without problems, land everything ok and when taxiing to the gate CTD or 1 hour flight and when approaching CTD is not reproducible.
at the last CTD the download dropped to 0.1MB that was during the ILS approach to EGLL 9R 5 miles for runway


Edit.I’ve just found that I’m not the only one who has had problems since Friday evening

I’m currently trying to reinstall the full game again and yes, I’m getting the same thing as most people. Just hangs at package 1/66. Constantly trying to download. I thought it would install during the night but woke up with only 4 packages done which was hardly anything.

I’ve tried a lot of things eg signing out xbox/store apps, used cmdprompt, edited usercfg and a different installation folder. No luck.

Guess I’ll have to wait till tuesday and see whether the new update pushes my download.

They are aware of this problem. Till now we must wait. Bing Data off resolve not the problem… that’s right.

1 Like

if you already know about the problem, it would be great if ASOBO or MS could tell us. This would save many users from having to post and search for a solution.
But the communication from ASOBO and MS is a different topic.

1 Like

5 days later, and I can’t get it to download packages from the update. Just retries and retries. All at super slow speeds. Any new news, please? I’ve done the suggestions to fix looping from months ago. Except I have not paid for Netlimiter.