Please help! microsoft store update loop


unfortunatly I can’t update: Yesteday I wanted to update from the store but had to pause. I wanted to resume today but it loops between downloading/completed, every second…
I tried to reset the store but it didn’t work.
I tried to update with the xbox app but error code 0x87e00013

Windows, the store and xbox app are up to date.
I want to try everything before reinstall it because with my bandwitch it would take several days of download.

thanks for your help!!

No promises but try setting your PC clock back to yesterdays date and approximate time (but ahead of when you paused)

If it works you may get problems further down the line or not, I can’t really say.

I have the same problem. The new update needs first to update in the microsoft store, but in my account in the microsoft store, there is no update to install.

In store there should be a 3 little dots symbol which might offer to ‘update all’ … if it’s there it should find the sim or will at least update your X-box app and that should see it

I had the same problem. You have to download the xbox app on ms store. Then launch it. Then close it. Go back to your ms store and the update should appear… yeah thats really ■■■■■ but thats the only way to get the update. Good luck


Reboot your PC after install X box app.

"We are aware that some users who own Microsoft Flight Simulator through the Microsoft Store are experiencing issues with installing World Update VI. This is an intermittent issue on the Microsoft Store that is affecting many titles including Microsoft Flight Simulator.

In addition to following the steps linked to in our update support guide, we also advise that you download and update the most recent Xbox app update from the Microsoft Store. This workaround has been working well for those not seeing the update:

  1. Go to the Microsoft Store and search for the ‘Xbox’ App.
  2. Download the ‘Xbox’ App and click ‘Launch’.
  3. Once the Xbox App is running, go back to the Microsoft Store to ‘Downloads and Updates’ and click ‘Get Updates’
  4. The MSFS update should start to download."

thanks for your answer,
I tried your steps but unfortunatly it doesn’t work for me. Since the begining I can see the update but it won’t resume (see first post). And when I try to launch MSFS nothing happens…

Hello I have the same problem, updated the latest version of xbox app, but when I run download and update, I do not have access to MSFS2020 update?
This is a recurrent issue, the automatic update of the earlier versions of MSFS was too simple and microsoft choosed a more complicated method that does not work!!!
I may uninstall and reinstall MSFS but I loose my settings.
Does anyone know where is the file which stores the settings?

You could try the recommendations in here:

or here:

1 Like

It’s in the cloud - you won’t lose anything other than (possibly) your graphics settings

1 Like

thank you so much! Nobody had indicated that it was necessary to install the xbox app on the pc to be able to have the FS update, I had 3 days trying to obtain the update.
Neither asobo in its solution to problems indicates that this app is necessary for it.

It is in the known issues and troubleshooting pages:

these zendesk tickets don’t work for me. It won’t resume correctly the download started yesteday in the store.

Nothing seems to work for me, I can’t install the game. I have tried 4 times a clean install with no avial
What a mess

Thanks FlightDomi. Your solution worked!

Thank you, this worked for me!

Hello. I had a problem with the Flight Simulator 2020 update. Thanks to FlightDomi, it worked for me via the Xbox App. I can finally fly7

What is going on… ??
Everything was working perfectly … got the update from the store to version -
Got to start the game and it wants to download the whole thing again,
So I left it overnight downloading and it seems to be in a loop and gets to about 5% downloaded then back to 0% again.
Why do they force these updates on us when everything was working ok?

Thanks a lot! It is a shame however that the xbox app is required for installing the update. The ms-store app seems to be blind for fs updates.

just a quick update: after reinstalling windows and MSFS2020 (sseveral days of download) all is fine. Just black screens in the default A320 cockpit but who still use it anyways…
Happy to be back on the track. :sunglasses: